Hell Yeah! > General Discussions > Topic Details
Xecutor Jan 5, 2013 @ 3:59am
Game is crashing on start
The game is crashing on the very start. No windows, no video, no resolution changes. Crash window appears immediately. I tried all suggestions from similar threads - nothing seems to work. Here are errors from event viewer:
Faulting application name: HELLYEAH.exe, version: 1.0.0.0, time stamp: 0x507437bb
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17965, time stamp: 0x506dbd3f
Exception code: 0xe0434352
Fault offset: 0x0000c6e3
Faulting process id: 0x1058
Faulting application start time: 0x01cdeb398fa6b2ce
Faulting application path: D:\Program Files\Steam\steamapps\common\Hell Yeah\HELLYEAH.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: cdacb947-572c-11e2-a58b-00e05293e054

Application: HELLYEAH.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.Xna.Framework.Content.ContentLoadException
Stack:
at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(System.IO.Stream, System.String, Int32 ByRef)
at Microsoft.Xna.Framework.Content.ContentReader.Create(Microsoft.Xna.Framework.Content.ContentManager, System.IO.Stream, System.String, System.Action`1<System.IDisposable>)
at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String, System.Action`1<System.IDisposable>)
at GameLibrary.LowLevel.CLASS_CONTENTMANAGER.Load[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String)
at GameLibrary.LowLevel.CLASS_SPR..ctor(System.String, System.String, Boolean, Microsoft.Xna.Framework.Content.ContentManager, Microsoft.Xna.Framework.Graphics.SpriteBatch)
at GameLibrary.LowLevel.CLASS_MOD_FADE..ctor(Microsoft.Xna.Framework.Game, System.String, Microsoft.Xna.Framework.Content.ContentManager, Microsoft.Xna.Framework.Graphics.SpriteBatch)
at GameLibrary.LowLevel.CLASS_MOD_FADE.Mod_FadeInit(Microsoft.Xna.Framework.Game, Microsoft.Xna.Framework.Content.ContentManager, Microsoft.Xna.Framework.Graphics.SpriteBatch, Int32, Int32)
at HELLYEAH_4_0.Game1.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean)
at HELLYEAH_4_0.Program.Main(System.String[])

Looks like game failed to open some kind of resource.
I tried 'run as administrator', and tried to fix permissions. No luck.
Showing 1-2 of 2 comments
< >
ZaxWaffles Apr 18, 2013 @ 5:14pm 
reinstall your Net Framework. make sure its version four though. and update your gpu drivers
Last edited by ZaxWaffles; Apr 18, 2013 @ 5:15pm
Xecutor Apr 18, 2013 @ 9:48pm 
I tried different versions of .net. And my video drivers are up to date. As you can see from stacktrace - the game fails to open some resource file. This is somehow related to localization I think. Interface language in my windows is set to english. But default locale is russian.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50