Dishonored > General Discussions > Topic Details
irondm11 Oct 11, 2012 @ 3:10am
Improving Default Graphics: Working Texture Filtering & Antialiasing Tweaks
Here's a few tweaks (You'll need Nvidia Inspector)

Basically, just match the settings in the profile I print screened to your own Dishonored profile in Nvidia Inspector (Make sure to apply changes once done).

Here's the pic:

http://s1062.photobucket.com/albums/t498/irondm11/?action=view&current=dishonoredaasettings.jpg

If you don't have Nvidia inspector, but have an nvidia card, here's where you can get it (Highly recommended for Nvidia users)

http://downloads.guru3d.com/NVIDIA-Inspector-1.94-download-2612.html

Once you've set up everything properly, things in game should look noticeably better in terms of anisotropy and AA

Anyways, hope this helps someone out.

enjoy and post feedback if this worked for you (It should if you have an Nvidia Card)

EDIT: If anyone needs help using Nvidia inspector, feel free to ask :)

EDIT 2: Another thing to note is that you'll need a geforce 500 series Nvidia card (at very least least) to handle the increased graphic settings ( 4x multisampling and 4x Sparse Grid supersampling).

Those of you with older Nvidia cards can try 2x multisampling and 2x Sparse Grid supersampling instead.

EDIT 3: (See Edit 4) Avoid FXAA injector (A programs that while useful in many games, like Skyrim, doesn't seem to work here), in my case it prevented Dishonored from launching. (See edit 4)

EDIT 4: OK so Apparently FXAA injectors (like sweetfx) will work if correctly configured. There's some pretty nifty graphic enhancements available with it, also, it's important to note that FXAA is much less resource intensive than the AA alternatives I propose. Thanks to Aeneas2020 for pointing this out.

Here's a link to the sweetfx utility: http://skyrim.nexusmods.com/mods/23364

EDIT 5: Screenshot 1:

- Using only in game AA
- fps locked at 60 using V-sync
- Everything in game looks very jagged and washed out

http://s1062.photobucket.com/albums/t498/irondm11/?action=view&current=2012-10-14_00001.jpg

Screenshot 2:

- Using Nvidia inspector for 2x Multisampling and 2x Sparse Grid
- FPS locked at 60 using V-sync
- Already a huge improvement over game defaults
- Still a bit of aliasing visible on the fence down on the water

http://s1062.photobucket.com/albums/t498/irondm11/?action=view&current=2012-10-14_000022x.jpg

Screenshot 3:

- Using Nvidia inspector for 4x Multisampling and 4x Sparse Grid
- FPS Drops to 50s in big areas and also when using blink (Phase ability)
- For me, this is the sweetspot. It's eliminated about 80% of aliasing in game and textures look noticeably better. Still, some of you will prefer to avoid the fps drops and stick with 2x

http://s1062.photobucket.com/albums/t498/irondm11/?action=view&current=2012-10-14_000034x.jpg

Screenshot 4:

- Using Nvidia inspector for 8x Multisampling and 8x Sparse Grid
- Frame Rate Drops to 30s and sometimes even lower
- Gpu heats up something fierce. Nothing dangerous though
- This setting eliminate pretty much all aliasing, but at great performance cost. I wouldn't recommend using this setting with a 500 series card.

http://s1062.photobucket.com/albums/t498/irondm11/?action=view&current=2012-10-14_000048x.jpg

Note: You'll probably need to resize the images on screen to notice the differences. I hate that Steam's screenshot utility doesn't seem to take 1920x1080 screenshots.
Last edited by irondm11; Oct 14, 2012 @ 11:59am
Showing 1-15 of 32 comments
< >
Caveman Oct 13, 2012 @ 4:43pm 
Hey thanks a lot for the screenshot. For Anti-aliasing compatibility however (at the top)- I could not find the 000000C1 ----- Should I just write that in?
irondm11 Oct 14, 2012 @ 6:28am 
yes, It's not listed as per default but you can just type it in yourself :)

Remember that if the hit in frame rate is too big for you, you can always reduce to 2x multi and sparse.

Anyway, enjoy and give some feedback if it worked on your rig. I had pretty noticeable improvements on mine (Will post screenshots):

PhenomII X4 970 @ 3.5ghz stock
8 gig ram
EVGA GTX 570 (Superclocked)
Last edited by irondm11; Oct 14, 2012 @ 7:04am
Electric_Assassin Oct 14, 2012 @ 7:16am 
For those with an AMD card and all I had to do was use Catalyst Control Center and make a new profile for Dishonored whit adaptive MSAA and Application enhance. Works beautifully.
irondm11 Oct 14, 2012 @ 7:40am 
Thanks for that E_A :) Was doing some research on how to achieve the same thing with ATI cards. You saved me the work!


Last edited by irondm11; Oct 14, 2012 @ 11:58am
Covert_Assasin Oct 14, 2012 @ 8:05am 
the game seems fine for me..I am just in the sewer at the beginning but it looks good with max in game settings. Nothing has been jagged for me at all and I am getting 90-120 fps on hd6950 2gb card. I might force some settings with ccc like the guy above mentioned. Just because I can.
irondm11 Oct 14, 2012 @ 8:08am 
Wait till you get to Dunwall. The Antialiasing issues are more apparent in open levels. That said, if they aren't bugging you then all the better.

I'm just offering solutions for those that want them :)
Scultimidonus Oct 14, 2012 @ 9:03am 
I have a Radeon HD7850 and forcing on AA through the CCC does not seem to make any difference. I made a profile using these settings:

Anti-Aliasing - Enhance application settings (should I turn AA on or off in the game?)
Morphological filtering - not sure if this should be enabled?
Filter - Standard 2xEQ (other option is Edge detect 12xEQ)
Anti-Aliasing Mode - Adaptive Multi-sample AA

Any help would be appreciated, those jaggies are nasty!
Last edited by Scultimidonus; Oct 14, 2012 @ 10:49am
Aeneas2020 Oct 14, 2012 @ 9:25am 
why don't people just use sweet fx combined with the nvidia inspector and control panel i have my game lookin sweet and i haven't got any slow down issues because i'm not using super heavy AA i'm just using the AA packaged with sweetfx
irondm11 Oct 14, 2012 @ 9:28am 
Sweet Fx completely prevented my game from launching. Pretty sure I had it properly configured.

Steve, just use Radeon Pro. It's like Nvidia inspector, but for ATI cards.
Last edited by irondm11; Oct 14, 2012 @ 9:31am
Aeneas2020 Oct 14, 2012 @ 9:31am 
that's odd works fine for me...what are your specs, drop me a pm we'll see if we can't get to the bottom of it
Scultimidonus Oct 14, 2012 @ 10:20am 
@irondm11 Thanks will check it out and report back.
irondm11 Oct 14, 2012 @ 10:26am 
Also Steve, make sure to override your in game AA if you decide leave it on, you should have the option somewhere in the ccc to disregard in game aa settings (assuming that is the case, not very familiar with ATI cards). If you're not sure how, then simply leave it off in game and use your CCC and radeon pro
Last edited by irondm11; Oct 14, 2012 @ 10:27am
Scultimidonus Oct 14, 2012 @ 10:40am 
Thanks, I was going by what Electric_Assassin said above, which was to use Enhance application settings rather than Override. I'll try your method though.

EDIT:
OK I tried 'Override application settings' - 4xEQ MSAA and it works! Eliminates the jaggies and makes the game look much better with no noticeable drop in FPS. :)
Last edited by Scultimidonus; Oct 14, 2012 @ 10:52am
irondm11 Oct 14, 2012 @ 11:52am 
Glad that fixed it for you

Enjoy :)
Electric_Assassin Oct 14, 2012 @ 6:15pm 
Originally posted by Steve M.:
Thanks, I was going by what Electric_Assassin said above, which was to use Enhance application settings rather than Override. I'll try your method though.

EDIT:
OK I tried 'Override application settings' - 4xEQ MSAA and it works! Eliminates the jaggies and makes the game look much better with no noticeable drop in FPS. :)

Glad to hear you got it to work. After reading your comment I went back and messed around with the settings and found that it wasn't having an effect when I was hitting "Apply" in the control center. What did make it work was saving the profile then hitting apply. And yea, you're right. "Override" looks much better than "Enhance". I'm keeping it there :)
Showing 1-15 of 32 comments
< >
Per page: 15 30 50
Date Posted: Oct 11, 2012 @ 3:10am
Posts: 32