Failedkamikazi Jun 2, 2013 @ 5:32pm
Won't even start.
I bought this game awhile agao when I still had windows 7. Ive since then upgraded to windows 8 and had to redownload it. I click launch and it does nothing. Anyone else have this problem?
Showing 1-15 of 29 comments
< >
Piotrek, Master of Design Jun 3, 2013 @ 5:08pm 
Well, it worked on Windows 7 and now works on Windows 8 for me, but you can try disabling Direct3D 10:
Library -> right click on Red Faction: Guerrilla -> Properties -> SET LAUNCH OPTIONS... and paste "-nod3d10" (without quotes)
Failedkamikazi Jun 3, 2013 @ 6:03pm 
Ive tried that and still no dice.
the_legend09 Jun 4, 2013 @ 4:45pm 
same for me your not alone
Lasergurka (Banned) Jun 5, 2013 @ 8:22am 
I don't get how a game can just suddenly stop working altogether, I tried downloading a non-steam copy aswell, crasches on start-up every time for me, on Win7.
Sir Edd601 the Poison Dragon Jun 8, 2013 @ 3:43am 
Doesn't work for me either :I
stevel Jun 8, 2013 @ 6:56am 
Hi, i just had this problem too, running win 8, 64 bit.
I ran the program directly from where it is installed, not from steam. Then the error message popped up about a missing file. xlive.dll in windows or somewhere.

The solution was to download the newer version of live for windows, it gives you a link but i will make it easy for you.

http://www.xbox.com/en-GB/LIVE/PC/DownloadClient

I just did this installed and now the game works, hope it works for you.
Hot Nachos ᴺᵃᶜʰᵒ Jun 12, 2013 @ 7:26am 
I had the same problem. Running Windows 8 with not the best specs.
How I fixed my problem is I went into
programfiles(x86)/Steam/Steamapps/common/RedFactionGuerrilla
and edited the properties of the rfg_launcher.

Right click rfg_launcher and select properties.
Go to compatibility tab.
Next, If you can, Check Run compatibility mode for: Windows XP (Service Pack 3)
Last check Run this program as administrator.

In addition, I installed live for windows. Then it worked. Thanks to Stevel.
http://www.xbox.com/en-GB/LIVE/PC/DownloadClient
the_legend09 Jun 19, 2013 @ 11:48am 
thnx hot nachos it worked
Failedkamikazi Jun 20, 2013 @ 3:28pm 
I dont know what worked. Either it was the windows live or the launcher but either way im able to play. Thanks Stevel and Hot Nachos.
Mattyes Jul 24, 2013 @ 7:03am 
Thanks guys this works
2spooky 2scary skilenton Aug 15, 2013 @ 1:22pm 
i tried all those things it doesnt work :(
Piotrek, Master of Design Aug 19, 2013 @ 10:26am 
You may also try disabling Steam Community In-Game.
Last edited by Piotrek, Master of Design; Aug 19, 2013 @ 10:27am
2spooky 2scary skilenton Aug 19, 2013 @ 11:29am 
already fixed the problem now with my own solution
Plaid Aug 19, 2013 @ 11:32am 
Originally posted by Grand Admiral Thrawn:
already fixed the problem now with my own solution

what was your solution?
NOPE Aug 19, 2013 @ 2:36pm 
can i get a windows live account without an xbox?
I'm also having problems
Last edited by NOPE; Aug 19, 2013 @ 2:37pm
Showing 1-15 of 29 comments
< >
Per page: 15 30 50