Awesomenauts > General Discussions > Topic Details
ZeeMox Nov 17, 2012 @ 8:08pm
"Initialising Steam" indefinitely
Can't get past the intro movie in this game. Nobody else having this problem? AH well, good thing it was a free weekend. Not going to be paying money for this crap.
Showing 1-4 of 4 comments
< >
RichardHell & the Sundance Kid Nov 17, 2012 @ 8:25pm 
I highly recommend looking around for a fix, cause the game is a damn blast. Have you tried posting in the forums? (might want to use language that's a bit friendlier than this).
royepi Nov 17, 2012 @ 8:56pm 
Restart Steam, I had the same problem.
Weeeeeeev Nov 20, 2012 @ 3:37am 
Your computer is not being very smart.
ZeeMox Nov 20, 2012 @ 8:06pm 
Sadly I did not have time to investigate the matter further on Sunday. I guess I should have tried to restart Steam to begin with, but with an unplayed backlog the size of mine, free weekends don't rank high on the play list. Ah well, maybe some future Steam sale if I'm feeling adventurous.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Nov 17, 2012 @ 8:08pm
Posts: 4