The Bridge > 一般討論 > 主題細節
LOL 2013 年 02 月 27 日 @ 下午 1 時 32 分
Game crashes when I start it.
I've uninstalled and re-installed the bridge several times now and when I start it the same problem occurs. If I hit any key, the game crashes.

Is there anything else I need to uninstall besides the local files? This game looks awesome.
顯示 1-15,共 24 則回應
< >
Ty_Taylor  [開發人員] 2013 年 02 月 27 日 @ 下午 4 時 54 分 
This is strange. Are you getting any error messages? I'm wondering if this is an issue with the installation of the prerequisites (.NET 4.0 and XNA 4.0) or the game itself. When you start it, does it show "The Bridge.exe" in the task manager?
Lgn 2013 年 02 月 28 日 @ 上午 3 時 57 分 
A friend of mine is having the same problem. And yes, the game show itself in the task manager when it crashes. Any idea how to help him?
Lgn 2013 年 02 月 28 日 @ 上午 5 時 09 分 
Ok fixed, he didn't have Windows Media Player installed.
Please mr Ty_Taylor fix this. I really want to play your game but i DON'T want WMP installed on my PC.
:D
Ty_Taylor  [開發人員] 2013 年 02 月 28 日 @ 上午 8 時 21 分 
Unfortunately, The Bridge was written in XNA, meaning that WMP is absolutely required to play music. It's a Microsoft-made game engine, meaning they tie in strong dependencies to the Microsoft-made audio player.
Lgn 2013 年 02 月 28 日 @ 上午 8 時 35 分 
Ok, you are excused because your game is freaking amazing! I'll buy asap even if i've to reinstall WMP :P
LOL 2013 年 03 月 3 日 @ 下午 5 時 10 分 
Sorry that it has taken so long. I do believe that the prerequisites are the problem.
When I first installed the bridge, I think I might have canceled the prerequisites in a way that made the game think they were installed when, in actualliy, they were not.
Ty_Taylor  [開發人員] 2013 年 03 月 3 日 @ 下午 10 時 57 分 
That should be an easy fix then. Try reinstalling them manually from these links:

http://www.microsoft.com/en-us/download/details.aspx?id=24872
http://www.microsoft.com/en-us/download/details.aspx?id=20914

It's okay if they're already installed on your computer. You won't hurt anything if you run these and they're already there.
LOL 2013 年 03 月 4 日 @ 下午 2 時 33 分 
Hmm, I installed both, then restarted my computer, and the game still crashed.

The way it crashes is this: I start the game, and it starts to run normally. Then, when I press any key, the game freezes, then crashes.
Ty_Taylor  [開發人員] 2013 年 03 月 4 日 @ 下午 5 時 18 分 
Oh interesting. That's good info...then it isn't the prerequisites at all. Can you hear the snoring or see anything on-screen (if you click "Play" in Steam then don't touch anything)?
LOL 2013 年 03 月 4 日 @ 下午 6 時 12 分 
I can hear the snoring and see the opening. it's only when I press a key that things go awrey. It seems that any key (including the windows key) will make it crash when I start it.
Ty_Taylor  [開發人員] 2013 年 03 月 4 日 @ 下午 8 時 09 分 
Thanks for the info. This is the first time I'm seeing a bug like this so I'm not exactly sure what's wrong. Are you using any software that might be interacting with your keyboard in some way, such as Joy2Key or something similar? Or is there anything non-standard about your keyboard or computer configuration in some way? I'm just trying to understand what's different about your computer that's causing this.
LOL 2013 年 03 月 5 日 @ 上午 6 時 33 分 
There's no extra software to mess it up. I do have a 64 bit computer though, could that have anything to do with it?
Ty_Taylor  [開發人員] 2013 年 03 月 5 日 @ 上午 8 時 48 分 
No, a 64 bit computer won't be causing this. I'm not able to reproduce this, so I think I'll need a bit more info from you before I can fix it. I'm not sure it is the act of pressing a key, or the act of pressing a key that does something which is causing it to break. The "z" key doesn't do anything in-game and definitely shouldn't cause the game to crash when pressed. When you press the "z" key only, does it crash?
LOL 2013 年 03 月 5 日 @ 上午 9 時 07 分 
Yes, the same thing happens when I only press z
Ty_Taylor  [開發人員] 2013 年 03 月 5 日 @ 上午 10 時 02 分 
This sounds to me like an XNA bug, as I'm using XNA to handle all of the input. I think you might be able to fix this by first uninstalling The Bridge through Steam, then going to Control Panel, then Add/Remove Programs, and then uninstall anything starting with "Microsoft XNA". Then try restarting your computer, and installing this: http://www.microsoft.com/en-us/download/details.aspx?id=20914 and then finally reinstalling The Bridge through Steam.

Does this fix the problem?
顯示 1-15,共 24 則回應
< >
每頁: 15 30 50