The Bridge > General Discussions > Topic Details
Fist of David May 16 @ 6:00pm
Controller Support on Mac
I picked this game up today after seeing it was finally availble for mac. I also noticed that it had controller support. For some reason, my wired Xbox360 controller wasn't being recognized by the game. I'm expecting a few bugs on the mac port since it just released today, but I was wondering if anyone else had any issues with this or if anyone could suggest a fix.
Showing 1-8 of 8 comments
< >
Ty_Taylor  [developer] May 16 @ 6:05pm 
Do you know if your controller works with other Unity-based games on Mac? One thing that I was able to do to get a controller working on Mac was to use the Tattiebogle driver (version 0.11) located here: http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver

Does that help?
Fist of David May 16 @ 6:20pm 
I'm not sure since I don't know which other games are made with Unity. I have Tattiebogle v 0.11 installed so it's just odd it's not working. This issue isn't really a big deal to me, just a minor inconveniance. Keyboard worked great as an alternative. I appreciate the quick response!
mua May 17 @ 10:52am 
I also have problems with my Logitch F310 controller on OSX. It doesn't seem to be recognized. It's not a big surprise, since I have the same problem with other games, but it also works with some games. Apparently Race the Sun is made with Unity, and it works with the controler, even though the mapping is not perfect.
Scooter May 22 @ 1:07am 
I also have the 360 controller and it doesn't work in the bridge. It has worked in all my other games.
Ty_Taylor  [developer] May 22 @ 10:15am 
Scooter, have you tried using the Tattiebogle driver for Mac? If so, are you able to see any inputs showing in the driver manager?
Scooter May 22 @ 12:48pm 
yes, I have that driver, and it is showing when i press buttons in the manager. I just updated it to .12 and it still isn't working.
Last edited by Scooter; May 22 @ 1:03pm
Ty_Taylor  [developer] May 22 @ 1:30pm 
Did you have 0.11 before? There are known issues with the 0.12 version (the latest) that cause the input to not get detected.
Scooter May 22 @ 1:45pm 
i did have .11 before
Showing 1-8 of 8 comments
< >
Per page: 15 30 50