The Bridge > General Discussions > Topic Details
marbleaide Jun 20 @ 10:23am
osx leopard?
Does this work on osx 10.5.8 leopard?
Showing 1-1 of 1 comments
< >
marbleaide Jun 28 @ 7:27pm 
I finally decided to just install it on my 10.5.8 machine.

Despite meeting all other specifications, no, this game does not appear to work on that version of OSX. :(
Showing 1-1 of 1 comments
< >
Per page: 15 30 50