Waveform > Genel Tartışmalar > Konu Detayları
Mac Problems
Everytime I open this game, it suddenly crashes. Every time I open it, it stops working. I have a Mac OS X Lion
< >
13 yorumdan 1 ile 13 arası gösteriliyor

Extract this to the Waveform SteamApps folder.
How do I find the SteamApps folder?
I have extracted this file and then the software no longer loads at all.
I am also on 10.8.2
I have sent a crash report to Eden Industries. Does that help you fix it? This is the top bit:

Application Specific Information:
Assertion failed: (ret == 0), function EnterCriticalSection, file
line 155.

I'd like to play this one. It's a bit disappointing that it does not work.
Uploading a new version to Steam now, we'll see what happens after that.

Definitely give the whole report if it doesn't load again. Both the terminal and the crash reporter should give a full backtrace.
En son flibitijibibo tarafından düzenlendi; 17 Şub 2013 @ 6:37am
New version just went up on Steam.
Gah, left another memory crash in that build. Even newer version is up now.
Game was crashing on startup. I right clicked game in library, properties/local files/Verify integrity of game cache, and it said a file was missing. It downloaded the file and after verifying again, it said it was okay. The game still crashes on startup. Hope this can be fixed soon. Thanks.
Try this version: http://www.flibitijibibo.com/waveformOSX.tar.bz2

Fixes crash on start for Snow Leopard (possibly Lion too).
Still crashes. I'm on Mountain Lion 10.8.2, if that helps.

EDIT. Game works. But it opens in a window that is stretched fullscreen. Not sure how to make it completely fullscreen. Edit again. Was in options and required restart.

Everything is working great. Thank you.
En son Blue Yoshi Egg tarafından düzenlendi; 18 Şub 2013 @ 2:48pm
Just noticed something that crashes the game. After looking at the pages of achievements, when you click back, the game immediately crashes and you get an error saying the game quit unexpectedly.
What does the report backtrace give us? I think I got a Linux report about this too, might be able to work around this tonight.
Nevermind, found it. Yet another memory corruption from the custom allocator.

Building now... will edit this when it's done, ETA 10 minutes.

EDIT: It's up now. Same location, same process, etc.
En son flibitijibibo tarafından düzenlendi; 18 Şub 2013 @ 3:42pm
I'm not sure if i'm the only one having this problem, but my game screen is way to big and i can't resize it. please help.
< >
13 yorumdan 1 ile 13 arası gösteriliyor
Sayfa başına: 15 30 50

Waveform > Genel Tartışmalar > Konu Detayları