Waveform > Allgemeine Diskussionen > Themendetails
Alkar 24. Jan. 2013 um 12:48 Uhr
Fixed problem starting the game on Ubuntu 12.10
When I double clicked the icon, nothing happened, no window shown and no sound played. And in steam It just showed "Played" as if I had played it. After running it from console I found this message:
./x86/waveform.x86: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
For some reason it did not load the library even when I had it installed in my Ubuntu.
So after running this command from directory /usr/lib:
sudo ln -s /usr/lib/x86_64-linux-gnu/libGLU.so.1 libGLU.so.1
The game started running and I even did few levels :)
Hope it helps someone if they have similar problems.
Zuletzt bearbeitet von Alkar; 24. Jan. 2013 um 13:02 Uhr
Beiträge 1-2 von 2
< >
Meh 30. Jan. 2013 um 9:52 Uhr 
That my also fix it, but it smells like a bit risky, as you are forcing a what I assume is a 32 bit executable (./x86/waveform.x86...) to use a 64 bit library (/usr/lib/x86_64....). How I solved this was to install the 32 bit version of the library. On my fedora machine: 'sudo yum install mesa-libGLU.i686', as you are on ubuntu, replace yum with apt-get or whatever it is that ubuntu has (or use a graphical software management tool)
flibitijibibo 31. Jan. 2013 um 23:15 Uhr 
The next Waveform update actually gets rid of the GLU dependency, so whenever that goes up you won't need to do this anymore.

Not sure when that'll happen, but I thought you'd like to know. :)
Beiträge 1-2 von 2
< >
Pro Seite: 15 30 50