Waveform > Obecné diskuze > Detaily tématu
Alkar 24. led. 2013 v 12.48 odp.
Fixed problem starting the game on Ubuntu 12.10
When I double clicked the icon, nothing happened, no window shown and no sound played. And in steam It just showed "Played" as if I had played it. After running it from console I found this message:
./x86/waveform.x86: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
For some reason it did not load the library even when I had it installed in my Ubuntu.
So after running this command from directory /usr/lib:
sudo ln -s /usr/lib/x86_64-linux-gnu/libGLU.so.1 libGLU.so.1
The game started running and I even did few levels :)
Hope it helps someone if they have similar problems.
Naposledy upravil Alkar; 24. led. 2013 v 1.02 odp.
Zobrazeno 1-2 z 2 komentářů
< >
Meh 30. led. 2013 v 9.52 dop. 
That my also fix it, but it smells like a bit risky, as you are forcing a what I assume is a 32 bit executable (./x86/waveform.x86...) to use a 64 bit library (/usr/lib/x86_64....). How I solved this was to install the 32 bit version of the library. On my fedora machine: 'sudo yum install mesa-libGLU.i686', as you are on ubuntu, replace yum with apt-get or whatever it is that ubuntu has (or use a graphical software management tool)
flibitijibibo 31. led. 2013 v 11.15 odp. 
The next Waveform update actually gets rid of the GLU dependency, so whenever that goes up you won't need to do this anymore.

Not sure when that'll happen, but I thought you'd like to know. :)
Zobrazeno 1-2 z 2 komentářů
< >
Na stránku: 15 30 50