Initium Novum May 30 @ 4:55am
laggy gameplay
The game has improved graphics compared to the years 1-4, but I think it isnt such a high end game that it should lagg. However, it does. LEGO Lotf does not have any problems on my system (i7@3.4GHz/660ti/8GB Ram) so I think it pretty much looks like a bug or something similar...
Has anyone experienced such performence problems and already found a solution?
It seems to help a little when I turn off V-Sync, but as I said, just a little...
Showing 1-9 of 9 comments
< >
Teun2408 Jun 6 @ 10:47am 
maybe can you try to reinstall it because you system would be able to run it without any problems
Catnip Mew Jun 26 @ 7:59am 
I know this thread looks like it's dead... but i had the same problems with my 4930k, 780Ti SLI, 16GB DDR3 1866Mhz Ram. I fixed it by forcing Vsync Through the Nvidia Panel and High Priority in the Task Manager.. SLI is disabled for me.
albertorcs Jul 2 @ 4:49pm 
same here. Phenom Xll 1055 8gb 1333 gtx670oc
dudesquared Jul 5 @ 9:59am 
Same problem for me, (i7 4770k@3.5ghz/GTX 780/16gb ram) forcing vsync and setting high priority in tm still doesn't help very much.
Hyorus Sep 22 @ 1:55pm 
For me lag when load new areas, after a few seconds gameplay is normal, dont know if is something with save, far i know this stutter should not happen.
Hyorus Sep 22 @ 5:41pm 
I made some tests, and something is wrong with this game, the stutter is actualy fps drop, in my case its drops from 150 fps to 33 fps and then go back to 150, very strange issue, same with low grapichs it drop from 400+ fps to 30-35, so configuration dont make difference,i dont think is ram related issue since it only use around 400 mb from ram.
Initium Novum Sep 29 @ 4:33am 
I read all your answers by the way, an thanks for still posting :)
Kythlyn Oct 22 @ 10:30pm 
I simply cannot believe that after all these years, there still isn't a reliable fix to the fps issue in this game. I set all of my settings to their absolute minimums, to the point that my GTX 660 and i7-2600K were running it at 700+ fps and STILL it would drop down to 30 fps for no reason whatsoever, over and over and over again. If anyone has solved this problem, please post your solution. I'm getting to the point where I might just buy it for a console, just for the more consistent framerate!
dkjravn Dec 18 @ 1:41am 
Same exact problem here.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50