Max Payne 3 > General Discussions > Topic Details
Alanvamps Jul 25, 2013 @ 5:16am
JUST BOUGHT MAX PAYNE 3 AND I CANT EVEN PLAY IT, STEAM PLEAS HELP
The game is stucked on initializing, it wont let me sing in to social club what is happening
Showing 1-15 of 44 comments
< >
✪Steve✪BERG♥ Jul 25, 2013 @ 7:13am 
here too. don't get it. why do I need a social club account? i wanna play a game i bought. nothing else. no registration.
Fabricioanoni Jul 25, 2013 @ 3:29pm 
Same here man.
I got an update that allowed me to initialize the game, but it wont connect to social club.
Dont know what the @#$@ is happening
Alanvamps Jul 25, 2013 @ 5:32pm 
im going pirate this game if they dont do something......... ):(
spyridonpp Jul 25, 2013 @ 7:11pm 
Same here.The game stucked on initialize.i can't sing to social club.I spend money for nothing and almost two weeks ...trying ...to...fixed...BUT NOTHING HAPPENS...
Indy Jul 25, 2013 @ 7:46pm 
I to cannot connect to Social Club to ply game. WTF
Fiend Jul 26, 2013 @ 2:18am 
I am having the same issue. It just hangs on the Social Club login page with a spinning circle. I have submitted a ticket to Rockstar but am yet to get a reply.
[MnT*]-MacD647 Jul 26, 2013 @ 7:47am 
I,m having the same problem, get to main screen & when i press start or enter nothing happens at all, just hope this gets sorted soon as.
Last edited by [MnT*]-MacD647; Jul 26, 2013 @ 7:50am
Lord Disick Jul 26, 2013 @ 8:08am 
I could play, just create a new account from social club, i'm playing since 2 hours ago
Ketchup Jul 26, 2013 @ 11:58am 
I had this problem happen to me twice. How i fixed this was by closing the game (Alt+F4), open the game again and hopefully it should let you sign in.
Fiend Jul 26, 2013 @ 1:01pm 
I tried that and it didn't work. I have submitted a ticket with Rockstar but have yet to hear anything.
[MnT*]-MacD647 Jul 26, 2013 @ 6:49pm 
This worked for me.... once the games loaded & instead of pressing the start button on the controller which nothing happens.... on the keyboard above the arrow keys press the home button either register or log in to ‎Rockstar Games Social Club & once thats done you will need to activate the game, hope it helps.
Jod Jul 27, 2013 @ 5:15am 
Same here, already tryed every possible fix available on internet and nothing works. The social club won't open.

What I already tryed:

* Setting up compatibility mode ((both mp3 and RGSC)win 7, win vista, win xp (all services packs)))
* Running as administrator (both maxpayne3 and RGSC)
* Running windowed ( -windowed at startup options)
* Uninstalling vcredist_x86
* Reinstalling all the distr at MP3_Installers folder
* Downloading and reinstalling RGSC from the Rockstar Website
* Pressing the HOME button

My next move is more bold, moving and renaming the folder and changing the windows registry, if nothing works I will open a ticket to have my money back. What troubles me the most is that nor steam nor rockstar gives a damn about this problem...

My Rig:

i7 2600k
XFX Radeon HD 6950
8 GB DDR 3 HyperX
Windows 7 Ultimate 64 bits (Full Updated)
[MnT*]-MacD647 Jul 27, 2013 @ 5:54am 
Honestly mate its got me baffled, i know this would be the last resort here, but have you thought about mabe re-instaling the game, never know buddy might just work 2nd time round.


H0ru2 Jul 27, 2013 @ 7:41am 
I had this problem, too. I solved it by going to Steam\SteamApps\common\Max Payne 3\MP3_Installers and run Social Club v1.1.0.6 Setup.exe. After that I could log in to Rockstar's "Social" Club and play the game.
I have no idea, why every Publisher/Developer needs a special association for his games and I'm not sure if I buy a (newer) game from Rockstar again, if they keep enforcing gamers into their little club thingy.
Fiend Jul 27, 2013 @ 8:08am 
Unfortunately I am running on a mac so that file won't exist for me :(
Showing 1-15 of 44 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 5:16am
Posts: 44