Max Payne 3 > General Discussions > Topic Details
Joroh Jan 3, 2013 @ 12:56pm
Problem with Social Club - Says I have no Internet connection.
****Fixed - Read my post the 10th of January for the fix that worked for me****


I am getting the error of "You have no internet connection" when trying to log into Social club. I looked it up and apparently it was very prominent when it first came out. I followed all I could find on my searches from ports, router etc. Nothing has worked and after owning for a week, downloading for 2 days I can't even play the game. I buy games I like, but this crap makes it worth downloading.

Anyone have some solid advice getting round this.

Cheers
Last edited by Joroh; Jan 10, 2013 @ 9:18am
Showing 1-15 of 36 comments
< >
Flexy Jan 3, 2013 @ 1:05pm 
Had the same problem. Unfortunately, there are no proper error messages and you have to try all kinds of things. I tell you what finally worked for me:
Turns out, I had the .NET framework 4.5 installed and thought I was all set, but I had to manually download the .NET framework 3.5 from microsoft.com and install it. Then I could finally log into social club. Weird!

Another problem I had: I got freezes during one of the early cutscenes always at the exact same spot and had to reboot every time. If you got this problem, open your games library, right click Max Payne 3 > Properties > Local files > Verify game integrity cache.
It will check if any of your files are incomplete or corrupted and redownload what is missing. I had to redownload 134MB and then it worked.
Joroh Jan 3, 2013 @ 1:15pm 
I will give this a go now (This doesn't make any sense to why it would stop it working). Will get back to you if it did work. Hopefully I won't have that issue, cause Verifying game cache is always my go-to thing if a game is not working.
Joroh Jan 3, 2013 @ 1:42pm 
Uninstalled 4.5 and installed 3.5. Nothing has changed though. Is there anything else I should be doing?
415*Fle@B@gL@ne Jan 3, 2013 @ 1:55pm 
A) I got 34GB game with all DLC pac in 1hr 30mins less
B)next few days after roomate has it now too got at about same speed Downloading
C)Comcast box and router by links for wire and non wire its encrpted
I am wondering if its a brand of router not all?
Just a thought im on links
Asks other whst on they use
Flexy Jan 3, 2013 @ 2:06pm 
Well, I didn't say uninstall 4.5 - that's still needed by other applications if you have it already installed.
Joroh Jan 3, 2013 @ 2:21pm 
Yeah got both on at the moment. Nothing is going through. Even with firewall and anti-virus turned off. So sad that Social Club ruins such a good looking game.
Ruff Jan 4, 2013 @ 1:04am 
im having the same issues Joroh and so far im seeing about 5-6 different fixes on addressing this. none working for me.
Joroh Jan 4, 2013 @ 7:18am 
Tried all the fixes I could find. Got in contact with my service provider, who kindly did lots of things to try and fix it. Switched my settings around but nothing has worked. From everything I can see it is a problem there end, but I have yet to get a reply from there support - after 2 messages and 5 days.
Last edited by Joroh; Jan 4, 2013 @ 7:18am
Stressthesky Jan 4, 2013 @ 8:07am 
Is this for when you're linking the accounts? Try this:

Right click your game in Steam->Properties->Set Launch Options->Type -windowed

See if that works.
AltruiSisu Jan 4, 2013 @ 1:18pm 
I purchased the game months ago and still haven't been able to play because of Social Club issues. I've tried every fix mentioned in the forums here multiple times to no avail. I sincerely hope you have better luck than me, Joroh. I'd love to actually play!
zendar Jan 4, 2013 @ 2:04pm 
there are offline fixes for the game but I couldn try them becaus of virus warnings :/ someone here who has some good advice in that direction?
Joroh Jan 10, 2013 @ 9:17am 
I have finally fix it after all this time. The support only just replied (Even thought I contacted on the day of my first post), and there fix sorted it. This was there fix and it worked straight away, I logged in and activated. No problem - no hassle.

"Thank you for contacting R* Technical Support. We are sorry to hear you are having an issue with our title. We deeply apologize for the delayed response.

Please download the patches from the following website:
http://support.rockstargames.com/entries/21540703-updated-11-15-12-links-to-max-payne-3-patches-launchers-and-social-club

Then turn off your antivirus software and re-install the patch as Administrator."

2 Patches with no anticirus and running as admin.

Hope it helps.
zendar Jan 10, 2013 @ 11:24am 
what helped for me was to reenable signaturedownload (or something like that) on xp antispy!!
=MGC= Bertd Mar 11, 2013 @ 10:10am 
Which of the 3 Patches shall I install? :S
daddyjames76 Sep 15, 2013 @ 6:08pm 

I had the same problem what I did is when it wouldn't let me in I hit home on the keyboard then log out of Social club, then log back in by entering in my email then my password then it let me in no problem. DO NOT I REPEAT DO NOT CLICK ON THE USER ON THE LEFT SIDE YOU MUST RE INTER IN YOUR EMAIL AND PASSWORD ON THE RIGHT...... hope this helps
Last edited by daddyjames76; Sep 15, 2013 @ 6:18pm
Showing 1-15 of 36 comments
< >
Per page: 15 30 50
Date Posted: Jan 3, 2013 @ 12:56pm
Posts: 36