Troll Hammer Mar 30, 2013 @ 10:51am
Linux version
when i launch it it just goes black and sends me back to desktop. Anyone have this happen?
Showing 1-8 of 8 comments
< >
ryuanlu [Linux] Mar 31, 2013 @ 1:42am 
Same here :)

Any idea ?
ryuanlu [Linux] Apr 1, 2013 @ 4:24am 
I found a solution in previous thread. You may give it a try.

1. Open ".local/share/Steam/userdata/{YOUR UID}/204060/local/config.txt" with any text editor.

2. Change SCREEN_WIDTH and SCREEN_WEIGHT with appropriate values (EX: 1920, 1080) then save and restart the game.

It works for me :)
Ogrelord Apr 1, 2013 @ 3:31pm 
I'm having this problem as well. I tried the solution your found, ryuanlu, but I haven't gotten the same success you have. Rather than getting the black screen, the game just terminates itself before anything pops up. At least I don't have to log out of my DE in that scenario.

I've set fullscreen to false on that same file, and it works then. I'd rather experience the game in fullscreen though.

Perhaps there'll be a Steam update? It worked fine when I played the Humble Bundle version around a year ago.
ryuanlu [Linux] Apr 1, 2013 @ 6:03pm 
I run steam client with Debian Wheezy and a NVIDIA gfx card. Perhaps there's something wrong with the proprietary driver (304.64). It additionally reports a strange resolution causing GLX error.

BTW, after I upgraded the driver to 310.40(lastest), Shank 2 got performance boost a lot (very smooth under Gnome shell). So I recommend to use a lastest NV driver.
Ogrelord Apr 1, 2013 @ 8:19pm 
Oh, well I'm using an AMD GPU right now, from their APU line. I have the latest stable driver, 13.1. Thanks though.
Troll Hammer Apr 2, 2013 @ 12:36pm 
thanks that fullscreen trick did the job
whisker Apr 6, 2013 @ 8:11am 
@ryuanlu i don't know who you are or what you are, but i love you and i want to have kids with you... xD
Thank you so much :D
kuul Apr 6, 2013 @ 2:34pm 
yes, setting a reasonable width did it for me. I think these problems originate from using more than one display, as the desktop surface gets enlarged to fit both (at least in my botched nvidea settings :)
Showing 1-8 of 8 comments
< >
Per page: 15 30 50