Superbrothers: Sword & Sworcery EP

Superbrothers: Sword & Sworcery EP

View Stats:
duckweedseattle Jan 28, 2014 @ 4:11pm
Problem using sword and shield
Very early into my first playing of the game (9% according to the little save meter) I am forced to fight an animated statue in a subterranean hallway while chased by an antlered-skull-headed dark ghost thingie. When it forces me into fight mode, the sword and shield don't work. I get hit and I die. Repeat.

Earlier in the game I encountered a giant wolfish creature and fought it. Each time it charged, I swung and hit it for one star of damage, then blocked with my shield. No problem. So why when it's time to fight the statue do my sword and shield not work? I see their icons on my screen, just like before, but clicking on them does nothing.

Is this a bug or a design feature? And if the latter, how do I avoid being forced to fight the statue? This is slightly annoying. Any help appreciated!
< >
Showing 1-4 of 4 comments
shawn·m Jan 28, 2014 @ 9:14pm 
With the statue, use your shield first, then strike with the sword.
Earlier in the game with the wolfish creature, just block his attacks with the shield until it gives up.

Unless bugged, this should work.
Last edited by shawn·m; Jan 28, 2014 @ 9:16pm
duckweedseattle Jan 29, 2014 @ 3:25am 
Thanks for the feedback. Looks like it's bugged. The sword and shield icons appear as normal but they looked "grayed out" and clicking on them does nothing. Then I die as soon as the statue strikes. I've tried it over and over many times, even reloading the game.

fyi with the wolfish creature I swung each time it charged and did a hit on it each time. When it got down to one star it ran away. So it looks like there's more than one way to defeat some of these critters.
Last edited by duckweedseattle; Jan 29, 2014 @ 3:27am
duckweedseattle Jan 29, 2014 @ 3:37am 
Just tried it again and, oddly, this time the icons were not grayed out. It works! Not sure what was going on all those other times, but I'm glad it's working now so I can continue with this interesting little game.
Last edited by duckweedseattle; Jan 29, 2014 @ 3:37am
shawn·m Jan 29, 2014 @ 5:31am 
Glad it's working properly!
< >
Showing 1-4 of 4 comments
Per page: 15 30 50