Shirokuroneko Aug 11, 2013 @ 1:29am
Cannoy play: wrong resolution in macbook pro with retina display
Hi, I've recentily purchased the game and installed it, but when trying to run it on my macbook pro (a retina display) I get a fullscreen game resolution too big for my screen, leaving contents out of reach. As a consequence of this I cannot either play nor leave the settings menu once I enter it (some contents including returing are out of the accesible part of the screen).

I've tried looking for the configuration file of the game and succesfully found it. There, I was able to change from fullscreen mode to windowed, but unfortunately you cannot set the windowed resolution from the config file, leaving again a window too big to be able to use or resize.

Does anybody have any ideas? I've basically paid for a game I can't play because of a bug.

Thanks.
Showing 1-9 of 9 comments
< >
xlynx Aug 11, 2013 @ 3:05am 
On Windows there's an executable in the game folder called VisionaireConfigurationTool which lets you set the resolution. It writes out its config to %LOCALAPPDATA%\Daedalic Entertainment\Satinav\config.ini

You are editing the default config file in the game folder. There should be a local one somewhere under /Users/ or /Library/ you can edit if the Mac version doesn't have VisionaireConfigurationTool.

My settings:
FULLSCREEN = NO
RESOLUTION = 1920x1080
UseTextureForWidescreen = YES
UseTextureCompression = DISABLED
UseTextureCompressionQuality = Low
MaxColorDepth = 32
UseHighResVideo = YES
UseAdditionalEffects = HIGH
UseSubtitles = YES
UseInventoryClick = NO
LOGLEVEL = ERROR
MusicVolume = 50
SoundVolume = 85
SpeechVolume = 85
Shirokuroneko Aug 11, 2013 @ 6:32pm 
Thanks, with your pasted settings I've managed to find out a workaround. The problem in my case is that in mac RESOLUTION is only set to 3 variables rather than to a specific resolution:

# RESOLUTION = {Auto|Desktop|Game}
# Auto - wide-screen support is activated if a wide-screen display is detected
# Desktop - current desktop resolution is used when game is started in full screen mode
# Game - game is initialized with the resolution specified in the game

Neither of these 3 values worked for me. However, I tried setting RESOLUTION = 1024x768 (for example) and it worked.

Now I can play, but it would be great if they fixed this issue so I could use the real resolution the screen has. Thanks for the help!
xlynx Aug 12, 2013 @ 2:55am 
It would seem they tried to automate the configuration tool and failed. Good troubleshooting!
David Jacobus Aug 13, 2013 @ 8:58am 
Hi, i'm a Macbook Pro with Retina Display user too, same problem here, and also with the game "The Book of unwritten tales". :(
eych Sep 16, 2013 @ 11:54am 
I believe this issue is fixed if you start the game when your Macbook is using a dedicated video card already (as opposed to the built in).

If the game itself forces Macbook to switch to the dedicated card as it launches — that's when the resolution breaks.

You can use an app called gfxCardStatus to see which card is used by the Macbook at the moment.
Last edited by eych; Dec 6, 2013 @ 5:25am
Shodan Nov 26, 2013 @ 7:34pm 
Just so you know, if you have this issue and enter the settings menu you cannot leave or quit the game since you cannot access the Return button with the mouse. The usual OS X Command-Q does work nor does any other usual tricks so you need to press Alt-Command-Esc to force quit the app.

I must say this is very poor to release this on the Mac in this state. In Window mode the game displays a double mouse cursor unless you make the window smaller than the desktop width then if you enter from the left, top, or bottom it will hide the desktop cursor but it won't let you leave to the right. And in full screen mode you need to enter Discrete mode first as mentioned above by etch using gfxCardStatus.

I think Daedalic should revisit their OS X support coding which seems more like a poorly implemented work around rather than something following Apple guidelines.
Shodan Nov 27, 2013 @ 4:11pm 
Just wanted to add you don't need to download gfxCardStatus to force discrete graphics mode, you can open System Preferences, Energy Saver and untick "Automatic graphic switching". This will force the system to use discrete graphics mode. Just remember to switch it back when done playing to save battery drain.
steliospota Jul 5 @ 4:45am 
Hi,
I bought Chains of Satinav to play on my MacBook Air and while I played it fine for about an hour, after I quit the game whenever I try to launch it I get the message "DSA quit unexpectedly". Before I quit the game I fiddled with the graphics settings a bit, by changing the colour depth from 32 to 16 bit. Since that's the only thing I changed I suspect that's why the game won't launch. However, I don't know how to change that setting while not inside the game. Any suggestions?
xlynx Jul 5 @ 2:54pm 
steliospota: if you can find your config file (see first reply), deleting it should fix your problem.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50