Highlander Jun 19, 2013 @ 5:11pm
my ships show like normal galleys, not longboats
and ive bought the units dlc and even the portraits dlc, a bug maybe?
Showing 1-15 of 15 comments
< >
Mandemon Jun 19, 2013 @ 10:42pm 
Longboats are only for Norse characters :(
Highlander Jun 20, 2013 @ 7:30am 
im using norse :( how can i fix this glitch?
:O Jun 20, 2013 @ 8:19am 
You need to make sure you're Norse and not controled by a Catholic King or Queen if you're some ones vassal.
Excidium Jun 20, 2013 @ 8:51am 
And to be clear you have be part of the Norse Religion and Culture
Highlander Jun 20, 2013 @ 11:36am 
im king of norway, and norse both in religion and culture, actually i havent seen a single longboat since i bought the dlc, just galleys
Vargas78 Jun 20, 2013 @ 11:43am 
What year is it in your game? I'm going out on a limb here but maybe later on the longboats get phased out by galleys which are considered a more advanced ship? Modern tech vs barbarian tech kind of thing?

Historically galley style ships were used in the baltic in the 1500's even. Possibly beyond that.
Highlander Jun 20, 2013 @ 12:30pm 
im currently at year 929, ive been seeing galleys since i started the game
Mandemon Jun 20, 2013 @ 12:37pm 
Okay, now it sounds weird. If you got Norse Character, with Norse Religion and you started with Old Gods scenario... You should have longboats.

Did you reform the religion? Of course, that most likely isn't it, if you haven't seen them since the begin...
Vargas78 Jun 20, 2013 @ 12:41pm 
Did you start the campaign before you had norse units pack or after? Again i'm grasping at straws here, but maybe if you got the unit pack after the campaign started, it means the extra units dont show up?

It's worth bringing it up in the paradox forums as well.
Mandemon Jun 20, 2013 @ 12:57pm 
Hmm, check the launcher, maybe for some reason the Norse unit pack is not equipped?
Highlander Jun 20, 2013 @ 4:25pm 
I started before and then started another one after i bought it, and yea the norse unit pack is loaded, i dunno maybe its some bug i was lucky to have :(, i even verified the game files but im still stuck with galleys
Vargas78 Jun 20, 2013 @ 4:50pm 
Set up a new game as pagan norse. In the 861ad scenario. If longships appear we can probably conclude its a glitch.

If longships still dont appear then its probably safe to assume that something is seriously amiss.
Highlander Jun 20, 2013 @ 6:08pm 
anyway i can contact paradox about it?
Turkrawr Jun 20, 2013 @ 6:31pm 
Originally posted by Highlander:
anyway i can contact paradox about it?
use the Pinned thread at the top to get in touch with people who are probably more helpful than us Steam users
Highlander Jun 21, 2013 @ 12:04pm 
so i just wanted to give an update about my issues with the longboats units, its fixed!, i dunno why but after i bought the hymns to the gods and the republic dlc, the glitch seemed to correct itself, anyways im glad to see my beloved longboats :)
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Jun 19, 2013 @ 5:11pm
Posts: 15