Fortune Summoners: Secret of the Elemental Stone
KLONOA WORKS Jan 18, 2013 @ 7:12am
slow frame in windows 8
Hi,
I moved to windows 8 the game was ok in 7 but in 8 it became slow frame X(
I tried compatibility to windows xp etc ... and same problem not work .

the game is fine at windowed mode but in fullscreen or zoom mode is slow

any solution I hope there is update to fix this problem :(
Showing 1-15 of 15 comments
< >
MrWildWolf Apr 1, 2013 @ 4:46pm 
I have the same problem :(
KLONOA WORKS Apr 5, 2013 @ 4:56am 
hopefully the team update and fix this problem :(
Rex Lupus Apr 7, 2013 @ 6:26am 
so... the problem haven't been fixed, yet. someone knows any solution? it's terrible to play like this and I don't have windows 7 to install right now :(
kaiser Apr 9, 2013 @ 11:01am 
i dont think itll be fixed

the distributors of this game are not even programmers and lizsoft (the author) has suspended his work as an indie game maker
INJurer May 8, 2013 @ 1:00am 
I have a simple solution for anyone experiencing this issue. After I tried all the possible compatibility settings to run it on full screen, including modifying the process priority and affinity I finally gave up.

At the end I figured it out that the solution can be more simple that I thought - just use windowed mode and lower resolution. Of course the problem with this approach is that it's quite uncomfortable to switch the video mode each time you want to run the game, so here's what you have to do to make it happen automatically:

1. Navigate to your SteamApps\common folder (Usually under C:\Program Files (x86)\Steam\SteamApps\common\)
2. Find the game folder "Fortune Summoners" and enter it
3. Right click on sotes.exe and select "Properties", then click on Compatibility tab.
4. Check the "Run in 640 x 480 screen resolution" (This is the exact resolution used by the game) checkbox.
5. Click OK.
6. Start the game and select "Windowed Mode", then Launch it.

That's it. The game will run in full performance, and will fill up your monitor screen. The only drawback in this approach that at the top of the game screen you'll see the window buttons, but it's not that big deal. The game runs smoothly and is playable nevertheless your native screen resolution.

I'll be glad to hear from you if this info was helpful for anyone.
MrWildWolf May 8, 2013 @ 4:28am 
Thanks INJurer i will try it later.
Rex Lupus May 8, 2013 @ 4:48pm 
I tried this, but it's anoyng to change resolution just to play one game and here with the lowest resolution is still a bit far from full scree. the only (and best) solution was to change back to windows 7. I installed 8 just to test it. I hated it.
INJurer May 9, 2013 @ 12:15pm 
Dear Rex Lupus,

By following my instructions, there is no annoying resolution change considering it's done automatically. Actually there are a lot of games that does exactly the same but you never notice it as it happens transperent for the end user. 640x480 is the native resolution of the game so the game is actually shown on full screen. If you change the resolution manually, as you probably did, you're limited to 1024x768 by Windows and the game will not fill your monitor screen.
Last edited by INJurer; May 9, 2013 @ 12:20pm
Edgar Rubio Rodilla Jun 10, 2013 @ 6:39pm 
Hi guys! I just found a solution!

1. Install DXGL from here: http://www.williamfeely.info/wiki/DXGL It is a wrapper for DirectDraw to OpenGL, so older games can run on newer systems.
2. Open the game's folder and make sure you don't have any compatibility options turned on sotes.exe properties.
3. If you EVER tried those compatibility options, open regedit.exe and search for any entry of sotes.exe under any appCompatFlags\Layers folder and remove it (if in doubt, remove any entry that contains sotes.exe, but I don't personally recommend this).
4. Open "Configure DXGL" and add the sotes.exe to the list. I left the default options.

Now you can run the game normally. In my case, the game gone from running at 10 fps to more than 50 fps.

Enjoy!
dorsk188 Jun 12, 2013 @ 2:22am 
Originally posted by Edgar R. Rodilla:
3. If you EVER tried those compatibility options, open regedit.exe and search for any entry of sotes.exe under any appCompatFlags\Layers folder and remove it (if in doubt, remove any entry that contains sotes.exe, but I don't personally recommend this).
4. Open "Configure DXGL" and add the sotes.exe to the list. I left the default options.
I've done all this, but the launcher still crashes saying there is still an AppCompat flag for the program. Any further help would be appreciated.
Edgar Rubio Rodilla Jun 12, 2013 @ 5:55pm 
Originally posted by dorsk188:
Originally posted by Edgar R. Rodilla:
3. If you EVER tried those compatibility options, open regedit.exe and search for any entry of sotes.exe under any appCompatFlags\Layers folder and remove it (if in doubt, remove any entry that contains sotes.exe, but I don't personally recommend this).
4. Open "Configure DXGL" and add the sotes.exe to the list. I left the default options.
I've done all this, but the launcher still crashes saying there is still an AppCompat flag for the program. Any further help would be appreciated.

Yeah, it's a little tricky. Seems like Windows store those keys in a couple of entries in the registry, at least. Just keep searching for "sotes.exe" in regedit with F3, starting from the first root folder until it says there's no more entries, removing any entry that says something like appCompatFlags. I think you need to restart after. Took me several tries, but had it working eventually.

And another update: just played a couple of hours and when there's a lot of action on screen, framerate drops to something like 20 fps in my A6-5400K. It seems that DXGL doesn't translate everything into OpenGL yet. It's still a lot better than getting 10 fps the whole time though.
Diogeno Jun 17, 2013 @ 3:06am 
Originally posted by INJurer:
I have a simple solution for anyone experiencing this issue. After I tried all the possible compatibility settings to run it on full screen, including modifying the process priority and affinity I finally gave up.

At the end I figured it out that the solution can be more simple that I thought - just use windowed mode and lower resolution. Of course the problem with this approach is that it's quite uncomfortable to switch the video mode each time you want to run the game, so here's what you have to do to make it happen automatically:

1. Navigate to your SteamApps\common folder (Usually under C:\Program Files (x86)\Steam\SteamApps\common\)
2. Find the game folder "Fortune Summoners" and enter it
3. Right click on sotes.exe and select "Properties", then click on Compatibility tab.
4. Check the "Run in 640 x 480 screen resolution" (This is the exact resolution used by the game) checkbox.
5. Click OK.
6. Start the game and select "Windowed Mode", then Launch it.

That's it. The game will run in full performance, and will fill up your monitor screen. The only drawback in this approach that at the top of the game screen you'll see the window buttons, but it's not that big deal. The game runs smoothly and is playable nevertheless your native screen resolution.

I'll be glad to hear from you if this info was helpful for anyone.
Why did i read it just now that i almost finished the game? :)
Thank you, it worked for me
TTiLer Jul 2, 2013 @ 7:06pm 
Originally posted by Edgar R. Rodilla:
Originally posted by dorsk188:
I've done all this, but the launcher still crashes saying there is still an AppCompat flag for the program. Any further help would be appreciated.

Yeah, it's a little tricky. Seems like Windows store those keys in a couple of entries in the registry, at least. Just keep searching for "sotes.exe" in regedit with F3, starting from the first root folder until it says there's no more entries, removing any entry that says something like appCompatFlags. I think you need to restart after. Took me several tries, but had it working eventually.

And another update: just played a couple of hours and when there's a lot of action on screen, framerate drops to something like 20 fps in my A6-5400K. It seems that DXGL doesn't translate everything into OpenGL yet. It's still a lot better than getting 10 fps the whole time though.

Why don't you make a short Guide covering all this stuff. Would easier to find that way.
Ram (Whitesister) Jul 12, 2013 @ 6:27am 
yes i have windows 8 too and can say the same about full window or zoomed mode, as soon as i do windowed mode i get fine fps else not so, maybe if you post it on the devs forums they might take action.
peeeveee Jun 22 @ 9:13am 
Thanks a lot, DXGL solves the issue on Win 8.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50