Disgruntled_Chemist Oct 26, 2012 @ 10:49am
Mac Version Graphics Issues
I am having severe graphics problems with the mac version. I am running it on the retina macbook pro and the polygons for Olaf or any NPCs arent loading, so I see a shade running around with floating Green bubbles near him.
Last edited by Disgruntled_Chemist; Oct 26, 2012 @ 10:21pm
Showing 1-14 of 14 comments
< >
Eoghan Oct 26, 2012 @ 1:43pm 
That happened too with Armored Princess and The Legend. It's a bit disappointing to see that they haven't fixed that issue yet.
nedclark Oct 27, 2012 @ 1:16pm 
Got it to work on my retina macbook pro by restarting machine and launching game before loading any other apps. Loading just about anything else results in the graphics issue (making the game unplayable). Embarrassing that steam and 1C haven't fixed this yet (present in the other Kings Bounty games). Would seem that doing a simple graphics memory dump on launching the game might fix the prob. Going to lose potential customers with this continued lack of basic app testing. At least there's now GoG for more mac ports.
>> Royal Lys ~ Oct 28, 2012 @ 7:12am 
Same here, didnt get it to work with nedclark's tip. Anyone else experiencing this ?
drum_spn Oct 28, 2012 @ 11:51am 
Same ♥♥♥♥! :((((
beesonpie Oct 28, 2012 @ 2:35pm 
Damn, was willing to buy this if they had fixed it. I had hoped that they might have fixed it for this and retroactively fixed KB: The Legend.
klimov80 Oct 29, 2012 @ 2:18pm 
doesn't work at all here. Everytime i try to launch it, i get graphic glitches and nothing happens. Don't know what to do. See the pic on my profile.
nedclark Oct 29, 2012 @ 5:46pm 
So after about 12hours of game time, I lost the graphics and tried the restart with that not working. Thinking that it might have something to do with the mac graphics card switching (between integrated and dedicated), I turned off the switching (power savings setting in mountain lion), and now it's working again!! I'm a huge fan of the series (playing crossworlds on parallels and boot camp in the recent past). Hope the rest of you getting working. (try the turning off the graphics switching)
klimov80 Oct 30, 2012 @ 6:43am 
fixed it that way : i changed all the video settings to min, and it worked. And now, believe it or not, i changed back all the settings to the max, and it works too... Only some sound glitches.. anyway, i would not recommend that game for mac users, not very smooth compared to other games with better graphics (Diablo III for ex)
nedclark Nov 12, 2012 @ 6:10am 
Having reviewed all the forums, and play tested several solutions, the lasting solution for me on my rMBP has been to force use of the integrated intel HD 4000 graphics chip set over the NVIDIA GeForce 650M discreet chip set using gfxCardStatus v2.3 app. For whatever reason, the developers at 1C and Steam haven't addressed this issue properly with any of the King's Bounty releases for the Mac. (Prior to purchase of Warriors of the North, I had been playing Crossworlds via parallels running off a boot camp partition.) It's a great series, and for everybody's sake, I hope the mac community gives it another chance...
BenSt88 Nov 12, 2012 @ 9:52am 
I just bought this game (my 1st Steam game ever) last night, after playing and loving the earlier KB: AP & KB: TL, also on Mac. Those games ran pretty well, though I had some occasional crash-to-desktop issues w/ KB: TL.

I'm disappointed to find out that WotN has problems, even after ostensibly 2 patches. I can see the figures and game world, but they're kind of washed out, like the textures are all on bare bones settings. I've restarted the computer; maxed out all the graphics options (and minimized them as well)--no change. Very frustrating. I love the gameplay and the humorous dialogue, but not sure I can continue playing.

nedclark if you could help me w/ figuring out how to do what you did w/ my system (I don't have Mt Lion), I would greatly appreciate it! EDIT: just realized w/out a MacBook Pro, I don't have 2 GPUs to begin w/, so it looks like we have separate issues after all.

MacPro 3.1, Quad-Core Intel Xeon @ 2.80 GHz; 2 GB RAM; Mac OS X Lion 10.7.5; ATI Radeon HD 2600 XT 256 MB

There's also problems w/ the mouse cursor after a fight, staying as an hourglass. Makes it hard to interact w/ dialogue options. And when I exit out of the game, invariably it has crashed and prepared an error log for Apple.

I'm dying to enjoy this game as it should be enjoyed, but unless I can get the graphics issue resolved, I'm likely to put it aside and hope for future patches to help me out. Kind of bummed my 1st Steam game has issues...though I don't blame Steam of course.
Last edited by BenSt88; Nov 12, 2012 @ 2:44pm
BenSt88 Nov 14, 2012 @ 6:37pm 
Bump

(I didn't want to start a new thread w/ nearly the exact same title as this one, though my issue is actually a little different. I can't get beyond low textures for everything, and I don't think I'll play any longer until I can get that resolved. Any other Mac users w/ this issue? I have tried, to no avail, putting all textures to low and then back, which worked for someone else...)
Sneaksie(RUS)  [developer] Dec 11, 2012 @ 7:00am 
Try the current build if you had 'disappearing models on nVidia cards' issue earlier, it should be fixed now.
Depthz Jan 12, 2013 @ 4:55pm 
the text rendering with an integrated intel card is awful (macbook air, intel hd 4000). any fixes? any way to force the game to run in its native resolution?
Moodyguy May 18, 2013 @ 12:05am 
i have same problem on my rMBP 15" OS X 10.8.3 (( (KB TL)
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Oct 26, 2012 @ 10:49am
Posts: 14