NECROMANCERFORLIFE Sep 21, 2013 @ 6:20am
0 Damage bug
i ran into a problem several times now a army of 2 ice dragons die because of a fire arrow with 100 Damage. but then 0 Damge is applied an the unit is dead. also happened to 10 Trolls. They died with 1 fire Arrow. anyone else having this issue?
Showing 1-7 of 7 comments
< >
peterbalada Sep 21, 2013 @ 1:57pm 
As far as I remember, this happened few times; however, under different conditions:
Berserkers zeroed by Evil Gremlin at Dead Man`s chest on Eastern Freedom Island, Horsemen downed by poison arrow of Skeleton Archers in Arlania, Knights and Demonologists destroyed by lightning spell in battle with the demon-mage Arkton in Demonis and then again the Demonologists annihilated by a single flaming arrow in Arlania. It seems to happen mostly in the middle of the game - after the first battle with Guilford when you don`t have the possibility to replenish the above mentioned units. How did I deal with the problem? I reloaded the saved game and changed the army composition and tactics or returned to the fight later.
But I would like to add that I haven`t encountered these difficulties recently, I usually play this game for 1-2 hrs a day at the present time.
NECROMANCERFORLIFE Sep 21, 2013 @ 2:21pm 
yes seems around the middle of the game and yes quicjk save before every battle is mandatory aswell as obligatory yet this shouldn't happen sice it never happened in KB The legend and KB Armored Princess. Is 1C/ Katauri working on it? would be nice.
SentosKarum Sep 26, 2013 @ 12:47pm 
Had this happen to me aswell.

Seems only to happen when fighting Deadly or above hero bosses and never happens for the player (Soothsayer + Blizzard = I generate enough hits to have this happen at least once in my favor if it could), can be triggered by AE spell splash (saw it happen with fireball during fthe Glaumogsomething castle fight underground in the Eastern Isles)
NECROMANCERFORLIFE Sep 26, 2013 @ 1:44pm 
well i guess i stay with my thing save reload its somewhat annoying but i still want to finish the game since it seems a random error.
s00pa Dec 20, 2013 @ 9:55pm 
ahh man this is frustrating! for me it seems to happen for units affected by fire or cold and then randomly when the affect is applied to the unit it says eg "fire does 0 damage" and the whole stack dies. Have been doing a particularly difficult boss battle and have attempted THREE times and every time this happens close to the end of the battle. I really don't want to give up an entire stack for no reason! why has this bug not been fixed!!!!?
Yarmonkey Jan 31 @ 8:42am 
It's been there for a long time. I'm a little astonished they haven't addressed it with the new expansion coming out.
king Apr 14 @ 3:03pm 
Originally posted by Yarmonkey:
It's been there for a long time. I'm a little astonished they haven't addressed it with the new expansion coming out.
yeah, what a fail...
Showing 1-7 of 7 comments
< >
Per page: 15 30 50