mermal Oct 18, 2012 @ 11:14am
not running
hey i have had this game for a bit of time and i have problem.
i have tryed installing it over and over and dooing all i can to fix it but i can not run this game.
i keep getting a error saying that it was not shut down propperly last time.

any help?
Showing 1-14 of 14 comments
< >
mmthewoodman1 Nov 10, 2012 @ 6:44pm 
reboot?
mermal Nov 11, 2012 @ 11:37am 
i have tryed that a few times now and nothing
Utopia GFR Nov 15, 2012 @ 1:12pm 
Still not working?
mermal Nov 16, 2012 @ 5:39am 
ya not working
cprince  [developer] Nov 17, 2012 @ 2:37am 
That's caused by an instant crash on startup, which is caused by broken video drivers. Try upgrading them to the latest ones.
cprince  [developer] Nov 17, 2012 @ 3:45am 
spotted a problem with Intel chipsets which I just uploaded a patch for, too.
Silv3r9 Dec 5, 2012 @ 4:06pm 
I reinstalled this game today and oh surprise, it gives me the same messsage as the OP making it unplayable. *sigh* I am not even gonna bother reinstalling revenge of the titans now...whatever the latest patch was...it broke the game for me :/
DarthPyro Dec 5, 2012 @ 9:00pm 
Having the same problem as the OP...kind of bugging me cause I love this game. :T
mermal Dec 6, 2012 @ 12:41pm 
i now know the problem

u must have a gpu to run the game for some reason
o my old labtop (not having one) i wa=s unable to run it, but now on my desktop (with a gpu) i am able to run the game.
cprince  [developer] Dec 8, 2012 @ 6:33am 
You don't need a dedicated GPU; Intel chipsets work too... provided you have up-to-date drivers. Microsoft and most OEMs ship Windows with broken drivers that crash instantly as soon as you try to use them. Just ask id Software about what happened with Rage...
Silv3r9 Dec 8, 2012 @ 10:21am 
I've been reading around on this issue and apparently the game was updated to included some newer and "fancier" graphics which for my netbook's puny integrated graphics means insta-crash. (yes, I do have everything up-to-date, the keyword here is netbook)

It's a damn shame because the game ran flawlessly for me before *sigh*

Please oh please do not mess around with Revenge of the Titans - I gave it a go and it still works so yay for that. Any plans for a patch to get the older graphics?
cprince  [developer] Dec 8, 2012 @ 1:16pm 
It completely turns off the fancy pants graphics if it detects "Intel" anywhere in the driver string... what chipset have you got in the netbook?

In the meantime there is a registry tweak that will force it to start up without fancy pants:

HKEY_CURRENT_USER\Software\JavaSoft\Prefs\net\puppygames\applets\/Titan /Attacks /Local\fancy /Pants

set that to "false"

in the meantime if you could find your logs (especially logs written in the .exe dir) that'd be very helpful!
Silv3r9 Dec 8, 2012 @ 7:47pm 
cprice, thank you for taking the time to reply.

My netbook runs the usual intel integrated graphics (media accelerator). I went looking for the tweak but the registry stops at titan/attacks/local ... there isn't a fancy/pants (lol) anywhere.

The only error log on the Titan Attacks folder is Java related (?) and can be viewed on the link:
https://www.box.com/s/ha6zh6yv0pq7mrngm7cq



cprince  [developer] Dec 9, 2012 @ 2:46am 
Great crash report :) If you have a little look down in it you'll see it's crashing in nglUseProgram (where of course it shouldn't be able to crash, as that's the graphics driver). Interestingly it shouldn't be running that code on an Intel chipset anyway, so at least I should be able to fix that.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50