cprince  [developer] Feb 16, 2013 @ 1:21am
Running fullscreen in Linux with Multi-Monitor
Many Linux distributions report some rather unusual screen resolutions to the game if you're running multi-monitor setups and this causes some odd quirks. I've just patched the game to allow you to specify a viewport in screen coordinates like this as a launch parameter (note the quotes around the whole string and the escaped quotes):

"vx=\"0\" vy=\"0\" vw=\"800\" vh=\"600\""

The origin (vx, vy) is the bottom left of the window (yeah, maths, eh!) in desktop screen space and vw and vh are the size. If you've got a game that starts up in some daft position halfway across two monitors, try putting in some appropriate values here to get it positioned to cover your entire main monitor.

You can also tweak the actual game .sh file and add the following option:
-Dnet.puppygames.applet.Game.windowed=true \
next to the other -D options (note trailing slash) and it will force it into windowed mode.

Cas :)
Showing 1-2 of 2 comments
< >
Thalic Feb 17, 2013 @ 7:15am 
Thanks, just what I was looking for ^_^
justsomeoneelse Mar 22, 2013 @ 12:05pm 
-Dnet.puppygames.applet.Game.windowed=true \
Thanks man. This one saved me some frustration.

For the Puppies: dual monitor setup, selected fullscreen - on th left hand steam was still showing, on the right hand monitor the left half of the full screen window showed up; the checkbox to go back to windowed mode was out of reach, being right of the right screen. And no way to get to it. Meh! But back to windowed mode now.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50