Tomb Raider

Tomb Raider

View Stats:
Tomb Raider > General Discussions > Topic Details
TheColorUrple Sep 26, 2013 @ 10:07am
TressFX SLI Glitching - SOLVED
Hi, just wondering if anyone else has run into this problem. I have Sept 2013 updated drivers and I'm running two 760's in SLI. My frame rate is fine, but the hair seems to be jumping around erratically with weird physics. There may be an easy fix, but I'm stupid.
Last edited by TheColorUrple; Dec 2, 2013 @ 8:47am
< >
Showing 1-15 of 15 comments
Cookie Eater Sep 26, 2013 @ 11:33am 
Do you have a screenshot?

I'm running a single 770 and though at times it appears to be a bit "Shampoo-commercial"-ish, it seems fine..
TheColorUrple Sep 26, 2013 @ 12:37pm 
Yeah, I ran a few tests and it's definitely an SLI problem. Even on one card though, the physics just don't seem right. In the wind especially, the hair will kick out in weird patterns. I guess I'll just disable it until they fix it (if ever that happens).

Here's a video I found on YouTube with the exact same problem. You'll see how annoying it looks.

http://www.youtube.com/watch?v=e3-VzIlqkN0


Originally posted by Cookie Eater:
Do you have a screenshot?

I'm running a single 770 and though at times it appears to be a bit "Shampoo-commercial"-ish, it seems fine..


Originally posted by Cookie Eater:
Do you have a screenshot?

I'm running a single 770 and though at times it appears to be a bit "Shampoo-commercial"-ish, it seems fine..
Commander Makara Sep 26, 2013 @ 2:36pm 
I can't comment with any real experience, byut I have heard that TressFX performs less spectacularly with nVidia driver software compared to AMDs.
I'm just throwing this out there as something I have seen mentioned a few times now, but I admit to not having any hard evidence or such to support either way.
R234 Sep 26, 2013 @ 3:05pm 
Also run a GTX 770, no such problem here. Perhaps TressFX just doesn't run right on the 760s...?
TheColorUrple Sep 26, 2013 @ 6:54pm 
Hey guys, I figured out what the problem was. I won't even begin to explain why, but this particular glitch was caused by EXCLUSIVE FULLSCREEN being turned to ON. As soon as I turned exclusive fullscreen OFF, TressFX started working beautifully in SLI!
Cookie Eater Sep 27, 2013 @ 5:48am 
Originally posted by SupOtcO YoceD:
Hey guys, I figured out what the problem was. I won't even begin to explain why, but this particular glitch was caused by EXCLUSIVE FULLSCREEN being turned to ON. As soon as I turned exclusive fullscreen OFF, TressFX started working beautifully in SLI! :B1:

Wonderful, I hope you don't mind if I quote this thread in future Technical issue threads.
TheColorUrple Sep 28, 2013 @ 4:14am 
Actually sorry, I spoke too soon. It definitely reduced the amount of glitching in the benchmark, so I thought it was gone...but there are still problems, depending on the physics of the moment. Also, I lost about 8 fps turning off exclusive fullscreen. Still looking for a better solution :(


Originally posted by Cookie Eater:
Originally posted by SupOtcO YoceD:
Hey guys, I figured out what the problem was. I won't even begin to explain why, but this particular glitch was caused by EXCLUSIVE FULLSCREEN being turned to ON. As soon as I turned exclusive fullscreen OFF, TressFX started working beautifully in SLI!

Wonderful, I hope you don't mind if I quote this thread in future Technical issue threads.
Last edited by TheColorUrple; Sep 28, 2013 @ 4:15am
TheColorUrple Sep 28, 2013 @ 4:41am 
Just a little update, I'm convinced that the SLI problem is specifically related to Alternate Frame Rendering, as if the two cards didn't calculate the hair physics in the same way and are oscillating the rendering rapidly between the two versions of where the hair is. Using Nvidia Inspector to turn off AFR eliminates the problem at the expense of frame rate. What I want to know is --

Is there a way to force the two cards to render two halves of the same screen?

I feel like this is possible with SLI configs but I don't know how to force it. I think that this would mostly eliminate the problem if the hair is not directly in the middle of the screen...
TheColorUrple Sep 28, 2013 @ 6:07am 
Forcing single frame rendering drops the framerate about 50%. That's not a good solution either.
igor.belin Sep 28, 2013 @ 9:01am 
игра загрузилась на английском как перевести на русский
TheColorUrple Dec 2, 2013 @ 8:46am 
Well, I figured it out. With the most recent drivers, the only way to keep good frame rates and smooth TressFX using SLI on Ultimate settings was the following settings:

V-Sync to OFF
Exclusive Fullscreen to OFF

Works like a charm now!
SpriteXP Dec 2, 2013 @ 12:39pm 
I had this problem too and turning off V-Sync was enough to fix the problem.
LeadStarDude Dec 2, 2013 @ 10:07pm 
Originally posted by TheColorUrple:
Hey guys, I figured out what the problem was. I won't even begin to explain why, but this particular glitch was caused by EXCLUSIVE FULLSCREEN being turned to ON. As soon as I turned exclusive fullscreen OFF, TressFX started working beautifully in SLI! :B1:
Dude! You are awesome! I did what you said & it fixed it for me as well. I am still using V-sync & it still is not giving me problems. Thanks.
LeadStarDude Dec 2, 2013 @ 10:25pm 
Originally posted by TheColorUrple:
Well, I figured it out. With the most recent drivers, the only way to keep good frame rates and smooth TressFX using SLI on Ultimate settings was the following settings:

V-Sync to OFF
Exclusive Fullscreen to OFF

Works like a charm now!
I went back & turned off V-sync also. I do not notice any tearing & I gained like 8fps. Now my average bench is getting 70+. :)
Qwinn Feb 7 @ 9:33am 
I know I'm necroing an old thread, but this one still comes up more often than most in searches, and I have new information to add.

The above advice to turn exclusive full screen off doesn't work for those wishing to play in 3D Vision, because exclusive full screen *must* be on for 3D Vision to work.

After a lot of experimenting, though, I discovered this: If you have VSync set to "Off" in NVidia Control Panel, which I did because I have never experiened tearing on my system, you will get the glitchy hair, regardless of your In Game settings related to VSync. Your framerate will also be effectively "unlimited", and will go as fast as your video cards can manage, but TressFX will look terrible.

If you set VSync to "Use the 3D Application Setting", then TressFX works fine *regardless of your in-game VSync settting, whether on or off*. Doesn't make sense, I know, but I can easily replicate this behavior. Also, if you have it set to "Use the 3D Application Setting" in NCP, at least in 3D Vision, you will be capped at 60 frames in game, even if you have VSync off. I get 60 frames whether I set the in game refresh rate to 60Hz or 120Hz. None of this is intuitive in the least, so I figured it'd be useful information to share.

FYI, I'm running on a 5930K processor and two 980Ti's in SLI.
Last edited by Qwinn; Feb 7 @ 9:37am
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Tomb Raider > General Discussions > Topic Details
Date Posted: Sep 26, 2013 @ 10:07am
Posts: 15