Tomb Raider > General Discussions > Topic Details
TheCloak Jul 25, 2013 @ 10:29pm
"Could not initialise DirectInput" Problem. Could Use Some Help, Please.
Hello, I have seen this problem posted somewhat scarcely in gaming forums and such, but all the answers do not seem to help me. As you can probably guess from the title, I am having problems playing the most recent Tomb Raider on steam. I got it over the summer sale and have been very excited to play it. I got about 52 minutes logged on the game because I have been playing it a little bit over the past 2 days with absolutely no problems. However, today I tried to put some new RAM in addition to my old RAM into my computer. The RAM did not work so I returned it. I put the RAM back into the correct slots (2 X 2GB sticks, 4GB total) and the computer booted up fine with no problems. However, when I went to run Tomb Raider to play it, when I start the game the screen goes black like it is going to play and then it crashes with an error stating "Could not initialise DirectInput!". I've seen that DirectInput has to do with controllers, keyboards, and mice, so I do not know how that is correlated with RAM. I installed DirectX but it said that I have all my directX up to date. I installed the newest drivers for my video card, an ATI Radeon HD 5850. Additionally, I've noticed that the sound on my computer has not been working properly, so that could possibly be an indicator. DxDiag does not show there to be any problems under the input tabs. I am really at a loss, I tried reinstalling the game and verifying the local files. It said there were 2 files corrupted or whatever and it installed them and when i verify it now there are no problems. If I could get any help at all I would be grateful. All the solutions on the internet point to reinstalling directX and drivers and disabling "Exclusive fullscreen" and I tried that and it didn't work. PCGamingWiki did not have a solution to my problem.
Thank you for your time.
Showing 1-4 of 4 comments
< >
Krya Littlemore Jul 25, 2013 @ 10:51pm 
Want to buy a paragraph.

Do you use a controller?
TheCloak Jul 26, 2013 @ 11:22am 
Haha yeah it is a block of text, sorry. I'm just getting annoyed and want to get my problem out there.

To answer your question, no I do not use a controller. I uninstalled my keyboard and mouse from device manager and let them reinstall but that didn't work. To reiterate what I said before, I think the fact that my sound card isn't being recognized may have something to do with it. I have an ASUS crosshair IV motherboard and it uses on-board sound. I noticed that my speakers or any headsets plugged into my computer did not work after i reseated my RAM and right now the speaker symbol on my toolbar has a red X near it although both my speakers and headset are plugged in. I did uninstall the HD sound driver thing from device manager and it has not reinstalled itself.

Thanks for your response.
Pain Jul 26, 2013 @ 11:24am 
бред
TheCloak Jul 26, 2013 @ 11:26am 
...sorry?
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 10:29pm
Posts: 4