Call of Duty: Black Ops II - Multiplayer

Call of Duty: Black Ops II - Multiplayer

View Stats:
HOW TO FIX- You Have been disconnected from the Black Ops 2 Servers.
ok guys, i know this is a huge problem for some of you, and i figured out how to fix it so i thought i should post it. OK.
Step 1:
Turn Your search preference to BEST

Step 2:
Make sure your NAT Type is set to OPEN. (this is the problem for most of you.)
If it is, your good to go. If not, continue to step 3

Step 3:
Change your NAT type to OPEN. This is NOT as simple
as it sounds. Its in fact VERY complicated, but only takes a few
minutes. Here is a link to a video that will show you how:

http://www.youtube.com/watch?v=riDlfxcKYBo

Enjoy BO2 Multiplayer guys!
< >
Showing 1-14 of 14 comments
[GTC] Gryphticon Jan 1, 2013 @ 9:36am 
I just restart Black ops 2 or I restart steam and start Black Ops 2, it works everytime.
Ok dude, you have NO idea what this is about. there is a glitch going on with NAT type and if you have it, you take extremely long to load maps and are disconnected from EVERY match. look on the forums, there are countless topics concerning it. and restarting doesnt help. this DOES.
Noxus Jan 2, 2013 @ 1:12am 
i tried this but i worked for a few minutes but it still says the i have been disconected
Bug Catcher Joey Jan 8, 2013 @ 5:12am 
Can you please explain to me how to 'Turn Your search preference to BEST"
if you click on public match then you must click on S and than you can set your ping to high or low
it doesn't work for me HELP ME please my mail is mennobarten@live.nl
a21389 Mar 4, 2013 @ 11:59am 
If you are having this problem post your computer specs here.
Carlsberg Mar 4, 2013 @ 3:58pm 
I posted this very problem to steam tech support and this is the answer, it worked for me and all is fine.

Quit steam if its running and browse to the steam/userdata folder and delete everything in it except steam.exe if its there,(on mine it was'nt). Start steam and it will recreate those files and correct errors.
Xterra Mar 4, 2013 @ 4:07pm 
That's not the only port that should be entered. There's also ...
TCP-UDP
3478-3478
4379-4380
27000-27050 <-------Steam ports
TheIntze™ Nov 12, 2014 @ 5:21pm 
Hey guys. Forget changing the NAT type, etc. I'm here to help. I actually got shocked that it worked. The reason was that your graphics card driver is not up to date, basically you have to update your driver. To do this,RIGHT-CLICK anywhere on your desktop. then click on SCREEN RESOLUTION at the bottom. the click on ADVANCED SETTINGS. after that, you're going to come across ADAPTER. then you just have to click PROPERTIES and then driver. Then when it says driver detail, update driver, etc. CLICK ON UPDATE DRIVER and then click on search automatically for updated driver software. Then windows would do everything for you. If this doesn't work, then be sure to comment. I fixed this issue yesterday and its the 13th of november 2014. This has to work for sure.
Pancake Faded Jul 29, 2015 @ 6:10pm 
Originally posted by ジェントルマン:
ok guys, i know this is a huge problem for some of you, and i figured out how to fix it so i thought i should post it. OK.
Step 1:
Turn Your search preference to BEST

Step 2:
Make sure your NAT Type is set to OPEN. (this is the problem for most of you.)
If it is, your good to go. If not, continue to step 3

Step 3:
Change your NAT type to OPEN. This is NOT as simple
as it sounds. Its in fact VERY complicated, but only takes a few
minutes. Here is a link to a video that will show you how:

http://www.youtube.com/watch?v=riDlfxcKYBo

Enjoy BO2 Multiplayer guys!
i cant find either of the 2 things that should be enabled could somone help me i have xfinity
BrigadierRosen Jul 30, 2015 @ 11:59pm 
the video is useless since i can't do step 1 or 3. my nat is strict and just disconnects me from almost every match which is annoying.

i wish treyarch and/or steam would sort their c.r.a.p out.
Ducké Oct 11, 2015 @ 12:49am 
it didnt work and I even tried all the port options


Originally posted by Xterra:
That's not the only port that should be entered. There's also ...
TCP-UDP
3478-3478
4379-4380
27000-27050 <-------Steam ports
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Jan 1, 2013 @ 9:34am
Posts: 14