Call of Duty: Black Ops II - Multiplayer
mirador Dec 22, 2012 @ 9:40am
Unable to join game session
Hi to all.
I have a problem when trying to join with friends to play BO2.
If they invite me and accept, then the game drops with the msg in the title. If i invite them, the same happens to them. After googling around did not find anything useful.
My NAT is strict and for some reason i cant make it OPEN and my friends have modarate.
Does anyone had the same problem as me?
Did anyone find a solution?
Showing 1-15 of 17 comments
< >
ASUS|BURY ME BANGED OUT Dec 22, 2012 @ 9:49am 
same here taken ages or isnt working
{DAT}S3RP3NT3S{NL}Rec Dec 22, 2012 @ 9:56am 
add port 3074 udp and 3074 tcp in your modum and it should do the trick :P
http://www.tobias-hartmann.net/2010/11/call-of-duty-black-ops-ports-fur-den-multiplayer/
Last edited by {DAT}S3RP3NT3S{NL}Rec; Dec 22, 2012 @ 9:57am
mirador Dec 22, 2012 @ 10:13am 
Originally posted by ^^1S3RP^^73NT3S^^4{NL}Rec:
add port 3074 udp and 3074 tcp in your modum and it should do the trick :P
http://www.tobias-hartmann.net/2010/11/call-of-duty-black-ops-ports-fur-den-multiplayer/

Done that. Even put 3478,27000 but nothing. My NAT remains strict and still cannot join with friends
LockeZeRo Dec 22, 2012 @ 10:45am 
Happening here too!
mirador Dec 22, 2012 @ 12:18pm 
Another thing i have noticed is, we cant be in a loby together but if a friend of mine plays a game and the server is not full i can join session, but not be together. How crazy is that!
Ob-la-di Ob-la-da Jan 15, 2013 @ 1:12pm 
exact same issue here aswell vasildur. dunno what to do
mirador Jan 15, 2013 @ 1:20pm 
I finally found the solution. You have to have NAT open to successfully invite and connect with friends, all of your friends. So the video that help me is the following....
http://www.youtube.com/watch?v=riDlfxcKYBo

In this video it talkes about Tohmson router. I guess similar settings can have any router.
SEVENNN Apr 29, 2013 @ 9:23am 
Same here.. we both have NAT:OPEN all ports are forwarded.we have very good internet connection but we can not join each others party(host) we have same internet connection!. wtf??? my 3rd friend is having same internet connection as us , with him i can connect and we can play together and my 1st friend can even join in 3rd friends party too but i can not join my 1st friends party or h... wtf? can someone explain or help ...????
Aeroshots Apr 29, 2013 @ 9:45am 
I have solved that issue! You can change it to Moderate or Open in just a few steps without downloading anything!
Go to start, Type in "network" or whatever it's called in your Language, Select network and open it from the windows list, Select your Router which you are connected with, rightclick Properties, it will open a new Window with current portforwarded Services, Add a new service, Call it BlackOps2, Select UDP and use 3074 as port, Put in your Internal IP, Can be found in Windows Command Prompt by typing "Ipconfig" click add, it will close the window you filled that info in, click in the other window Ok and restart Call of Duty: Black Ops 2 - Multiplayer and it should be changed!

Kind regards.

~Aeronizor.
Last edited by Aeroshots; Apr 29, 2013 @ 9:48am
mirador Apr 29, 2013 @ 11:30am 
Originally posted by SEVENNN:
Same here.. we both have NAT:OPEN all ports are forwarded.we have very good internet connection but we can not join each others party(host) we have same internet connection!. wtf??? my 3rd friend is having same internet connection as us , with him i can connect and we can play together and my 1st friend can even join in 3rd friends party too but i can not join my 1st friends party or h... wtf? can someone explain or help ...????

As you said you have the same internet connection and i am thinking that your computers are in the same network. Try this: put static IP to yous network cand (it does not matter if it is a usb wifi, it is recognised as a network adapter). You can do this by finding your network cards at network and sharing center, right click -> properties and click properties at the internet protocol version 4. Put static ip's and try to connect all 3.
SEVENNN Apr 29, 2013 @ 12:48pm 
vasildur

when i'm trying to static my ip my internet connection shut downs... then i must restart comp>go to network and sharing>adapter settings>local area connection>properties>internet protocol 4 >set obtain ip address automatically and DNS servers too! finely my ip is dynamic :|

Aeronizor
i'm in my router properties,how to add new service? theres no option like that...
mirador Apr 29, 2013 @ 4:01pm 
Sevennn that is most peculiar. Let me give you an example of what i mean.
Lets say your router is 192.168.1.1 and you do not have any other equipment attached to the network exept the 3 PC.
You can put 192.168.1.10/11/12, subnet 255.255.255.0 and default gateway/DNS server 192.168.1.1.
All of the above is an example and it depends of the IP of your router.
The other thing that i am thinking is that you use a duplicate IP. Without noticing you may have an IP conflict when you put static.
I cannot see any other reason why your internet connection shuts down.
And in most cases, using static IPs resolve the issue of multiple computer in the same network to connect easily.
SEVENNN Apr 30, 2013 @ 4:41am 
valisidur i have CISCO router E1550.I have iPad connected (via wifi) nothing more.Only 1 PC and iPad.I tryed settings that you advised
198.168.1.12
255.255.255.0
198.168.1.1
---------------------
198.168.1.1
168.168.1.2(alternate DNS)
but still internet connection shuts down and then i must change to obtain automatically.I think i have duplicate IP as you said thank you for that.When i'm viewing my ip its 78.139.184.*** !!.
but my IPv4 adress is 198.168.1.107. DAMN IT !!! what to do?

P.S. Thank You
mirador Apr 30, 2013 @ 11:41am 
Ok, now 78.139.... must be your external IP, the IP you provider gives you to connect to the internet.
Try something different. You can check through command prompt (start-run-cmd) the dynamic IP your router gives 2 all your PC. Then put this IP as static (and subnet and default gateway). Do not use alternate DNS 'cause it does not matter. And see if you get an internet drop in you pc.
If that happens again, you must check the DHCP server option, under the network TAB of your router. Maybe something is wrong with this settings and when you put a static, the DHCP server of your router drops you out of connection. If you have never tempered with it or anyone else i cannot see why that happens but it worth a look.
Last edited by mirador; Apr 30, 2013 @ 11:41am
SEVENNN Apr 30, 2013 @ 1:40pm 
i changed ip (subnet and default) but it shuts down again.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Dec 22, 2012 @ 9:40am
Posts: 17