The Precursor Feb 26, 2013 @ 11:32am
HKship.exe crash fix for AMD users!
This fix worked for me and three friends, so I thought I'd post it here. I don't know how nvidia users would go about this but I'm sure it's possible.

Step 1: Open the vision engine controll center and click on "Gaming" then " 3D application settings".

Step 2: Look for the button that says "Add" and click on it.

Step 3: Browse to your sleeping dogs folder in Steamapps/common and click the HKship.exe icon, then click open.

Step 4: You will be told there is a profile set up for this already, allow it to be overwritten.

Step 5: HKship.exe will now appear in a small scroll bar. Click on it.

Step 6: Scroll through its settings to "wait for vertical refresh" and set it to "always off".

Step 7: Launch the game and wait at least a minute. It'll white screen but eventually should launch without a crash.

And that's all there is to it. I've tried to be as clear as I can with this, and I can't guarantee 100% success rate but it seems to work well. Please comment if you get a good result so more people can see!

Second Fix Posted in this thread, if the first doesn't work:


Originally posted by Steven:
I used to get the same problem until this afternoon, i found a solution that fixed this problem, im on an AMD processor by the way...

.. The following lines were wrote by AssassinKID , so I'm not the guy who found the solution, all that belong to him..

1. Kill the game with Task Manager and exit Steam.

2. Now go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\" and delete the following files: "D3D11Install_2010.exe", "vcredist_x86.exe", "D3D11InstallHelper.dll"

3. Go to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs" and delete "HKShip.exe", "d3d11.dll" and "dxgi.dll"

4. Now start Steam, right click on "Sleeping Dogs" and select "Properties" then "Local files" then "verify integrity of game cache" and wait until finished (this step downloads and replaces the files you deleted before)

5. Go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\DXRedist"

6. Run "DXSETUP.exe" (this copied some files even though my directX was already latest version)

7. Go up one folder to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist" and run "vcredist_x86.exe", choose "Repair".

8. Go back to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs", right click on "HKShip.exe" and choose "Properties" > "Compatibility", check "Run as Administrator" and "Run this program as: Windows 95" or "98/Me".
Last edited by The Precursor; Mar 3, 2013 @ 4:51am
Showing 1-15 of 16 comments
< >
arwdassain Feb 26, 2013 @ 5:33pm 
thank you it worked for me.
The Precursor Feb 27, 2013 @ 9:38am 
Originally posted by arwdassain:
thank you it worked for me.

Cool, cheers for replying. I want as many people as possible to find out about this fix! :D
Handres the Warrior Feb 27, 2013 @ 1:35pm 
I tried your trick and it still does not load fr me. Keep getting the same, Not Responding, message. No matter what trick I try, the game just does not want to load.
The Precursor Feb 27, 2013 @ 2:08pm 
Originally posted by Handres the Warrior:
I tried your trick and it still does not load fr me. Keep getting the same, Not Responding, message. No matter what trick I try, the game just does not want to load.

Is it thw white screen/HKship error you're getting? If so, what GPU do you use?
Steven Mar 2, 2013 @ 7:26pm 
I used to get the same problem until this afternoon, i found a solution that fixed this problem, im on an AMD processor by the way...

.. The following lines were wrote by AssassinKID , so I'm not the guy who found the solution, all that belong to him..

1. Kill the game with Task Manager and exit Steam.

2. Now go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\" and delete the following files: "D3D11Install_2010.exe", "vcredist_x86.exe", "D3D11InstallHelper.dll"

3. Go to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs" and delete "HKShip.exe", "d3d11.dll" and "dxgi.dll"

4. Now start Steam, right click on "Sleeping Dogs" and select "Properties" then "Local files" then "verify integrity of game cache" and wait until finished (this step downloads and replaces the files you deleted before)

5. Go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\DXRedist"

6. Run "DXSETUP.exe" (this copied some files even though my directX was already latest version)

7. Go up one folder to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist" and run "vcredist_x86.exe", choose "Repair".

8. Go back to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs", right click on "HKShip.exe" and choose "Properties" > "Compatibility", check "Run as Administrator" and "Run this program as: Windows 95" or "98/Me".
The Precursor Mar 3, 2013 @ 4:50am 
@Steven. I'll add that to the OP.
Steven Mar 3, 2013 @ 6:33am 
Great, hope it works for you, it worked for me and i'm enjoying the game now ^^..
Rossos May 1, 2013 @ 1:14pm 
Setting game to Compatibility Mode Windows 95 solved it for me.
Originally posted by Steven:
I used to get the same problem until this afternoon, i found a solution that fixed this problem, im on an AMD processor by the way...

.. The following lines were wrote by AssassinKID , so I'm not the guy who found the solution, all that belong to him..

1. Kill the game with Task Manager and exit Steam.

2. Now go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\" and delete the following files: "D3D11Install_2010.exe", "vcredist_x86.exe", "D3D11InstallHelper.dll"

3. Go to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs" and delete "HKShip.exe", "d3d11.dll" and "dxgi.dll"

4. Now start Steam, right click on "Sleeping Dogs" and select "Properties" then "Local files" then "verify integrity of game cache" and wait until finished (this step downloads and replaces the files you deleted before)

5. Go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\DXRedist"

6. Run "DXSETUP.exe" (this copied some files even though my directX was already latest version)

7. Go up one folder to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist" and run "vcredist_x86.exe", choose "Repair".

8. Go back to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs", right click on "HKShip.exe" and choose "Properties" > "Compatibility", check "Run as Administrator" and "Run this program as: Windows 95" or "98/Me".
Percele Jul 19, 2013 @ 1:36pm 
Awesome, thanks...
Ra1dMaX Jul 29, 2013 @ 7:01pm 
might add that if you are starting to black screen check if the d3d11,dll and dxgi.dll files are in the Sleeping dogs Folder with HKship...as installing the game from steam doesnt supply them for some wierd reason
this was the cause of black screen on startup
Marshermallow Jul 30, 2013 @ 9:08pm 
this got the game running but it's stuck in windowed mode for me, alt+enter wont work, any ideas?
Marshermallow Jul 30, 2013 @ 9:09pm 
Originally posted by Ra1dMaX:
might add that if you are starting to black screen check if the d3d11,dll and dxgi.dll files are in the Sleeping dogs Folder with HKship...as installing the game from steam doesnt supply them for some wierd reason
this was the cause of black screen on startup
I am not seeing these two files in that folder the game is working though...?
TEMPTATIONS Jul 30, 2013 @ 11:14pm 
mine juz keep on saying hkship.exe has stopped working pls help
babycakes Aug 2, 2013 @ 5:02pm 
I also don't have the DLL files that are supposed to be in the game folder....
Bwraem Aug 16, 2013 @ 3:19am 
3. Go to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs" and delete "HKShip.exe", "d3d11.dll" and "dxgi.dll"
I also can't complete this step because i don't have the files: "d3d11.dll" and "dxgi.dll".
I hope that you can help me because i like the game very much.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Feb 26, 2013 @ 11:32am
Posts: 16