alanwow_ Feb 20, 2013 @ 4:51am
Stuck on loading screen
Whenever I hit "New Game" it goes to the loading screen and then freezes. I tried verifying cache, updating drivers, waiting over an hour, change all settings to low, reinstalling, restarting the computer and nothing works. Can anyone please help? I definitely meet the requirements. I don't know why it won't work..
Showing 1-5 of 5 comments
< >
AssassinKID Feb 23, 2013 @ 6:36pm 
I used to get stuck on the first mission load screen (2 guys on the boat image), I even left it to load for hours but it didn't get past it. I did these steps to solve the problem:
1. Kill the game with Task Manager and exit Steam.

2. Now go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\" and delete the following files: "D3D11Install_2010.exe", "vcredist_x86.exe", "D3D11InstallHelper.dll"

3. Go to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs" and delete "HKShip.exe", "d3d11.dll" and "dxgi.dll"

4. Now start Steam, right click on "Sleeping Dogs" and select "Properties" then "Local files" then "verify integrity of game cache" and wait until finished (this step downloads and replaces the files you deleted before)

5. Go to: "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist\DXRedist"

6. Run "DXSETUP.exe" (this copied some files even though my directX was already latest version)

7. Go up one folder to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs\redist" and run "vcredist_x86.exe", choose "Repair".

8. Go back to "C:\Program Files (x86)\Steam\steamapps\common\SleepingDogs", right click on "HKShip.exe" and choose "Properties" > "Compatibility", check "Run as Administrator" and "Run this program as: Windows 95" or "98/Me".
alanwow_ Mar 6, 2013 @ 9:51pm 
I've actually seen your post on this before and I tried it. I made sure I did everything correctly, step-by-step. But it still failed to move past the loading screen. Thanks for the suggestion though!
xionshift May 11, 2013 @ 1:29pm 
I'm also having the same issue. First, it was getting the game to load issues. Fixed that. Now I can't seem to get passed the loading screen, even after going through the steps that previous community members have posted. Anyone have any other tips/tricks to get this working?
Watch dogs sucks May 13, 2013 @ 11:52pm 
You might as well just stay stuck on the loading screen because that's best part of the game. It seriously just gets worse. Don't play this game.
babycakes Aug 2, 2013 @ 4:46pm 
I too have been trying all of the different steps and such to get this thing working and none so far have worked :(. I've changed the compatibility mode, tweaked with Redistributable installation and DirectX installion. No luck with any of them :(
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Feb 20, 2013 @ 4:51am
Posts: 5