twitch.tv/peachypixel8 Dec 28, 2012 @ 2:05pm
HKShip not responding (FIXED)
Windows 7 64-bit (should work on 32bit windows 7 too)
After google'ing the crap out of this error and finding half fixes all over the place I thought I would share my fix with you

go to:
windows instal drive (C:):\Program Files (x86)\Steam\steamapps\common\SleepingDogs
and right-click HKShip.exe
left click properties and select 'Compatibility' tab
now check the box for 'Run this program in compatability mode' and use the drop down to select Windows 7
then check the box in 'Privilege Level' to Run this program as an administrator

I hope this has helped you play this otherwise great game and lets hope for a fix soon

*edit*
This is for the error freezing the ingame action, not menu's or boot

fyi my specs are:-
quad core i5 3.40GHz
8GB RAM
Nvidia GeForce GTX 550 Ti
Windows 7 64bit Home premium
Last edited by twitch.tv/peachypixel8; Jan 6, 2013 @ 10:47am
Showing 1-15 of 41 comments
< >
Kolyaaz Dec 28, 2012 @ 2:10pm 
when i go to start a new game freezes
twitch.tv/peachypixel8 Dec 28, 2012 @ 2:52pm 
after this fix? is it the same HKShip error? 64bit or 86x?
Tuffcooke Jan 5, 2013 @ 11:46am 
i tried this, but there was no compatibility tab in properties.
twitch.tv/peachypixel8 Jan 5, 2013 @ 5:00pm 
Originally posted by Tuffcooke:
i tried this, but there was no compatibility tab in properties.
oh.. perhaps its the version of win7. I am using Windows 7 Home premium are you on the same? does the right click give you a context menu with run as administrator and does that solve your issue if its done?
abm69 Jan 6, 2013 @ 6:31am 
when i click HKShip all i get isd3d11.dll was not found
abm69 Jan 6, 2013 @ 6:31am 
im on xp home
twitch.tv/peachypixel8 Jan 6, 2013 @ 8:28am 
Originally posted by abm69:
im on xp home
Sorry I would have no idea on XP
Annihilasian Jan 6, 2013 @ 9:40am 
followed the steps, still no go =/
twitch.tv/peachypixel8 Jan 6, 2013 @ 9:57am 
Originally posted by Annihilasian:
followed the steps, still no go =/

oh noes! It seems the only person this fix has helped is myself :/

Have you tried deleting the local data, re-downloading & installing it, then aplying the fix?
DoubleD Jan 6, 2013 @ 10:02am 
I just created a desktop short cut and that fixed it for me.
theSecondAgent Jan 6, 2013 @ 10:27am 
I've tried everything I have found on the internet to fix this issue, but still no such luck. I'm 100% sure though my problem is linked with a fellow Steam users message. Please let me know if you have any suggestions!

"Okay, well I REALLY wanted this game right? well uhm I got it.. one download did no problem but now there is this one download (D3D11Insall) to be exact, that PISSES ME OFF. Like really its says exactly this "Please Install latest service Pack. For instructions on how to install the latest service pack, see Microsoft knowledge article KB935791 (http://support.microsoft.com/kb/935791)." thats all. LITERALLY. I run windows 7 and this is a Vista/Xp problem? rage. I posted this same thing on the steam support site right? welll no response. LITERALLY so I'm forced to come to you, the hopefully helpfull people here. If you help. Your ♥♥♥♥ing jesus. okay I'm out thanks!"
Blindside203 Jan 6, 2013 @ 8:49pm 
This game is nothing but a $50 brick. Can't play for more than 2 minutes without getting crashes. DO NOT BUY untill they fix this crap.
twitch.tv/peachypixel8 Jan 7, 2013 @ 5:32am 
It is a great game. It's just unfortunate that you have to manually fix it before you can play it
abm69 Jan 7, 2013 @ 7:35am 
yeah iv put directx back in reinstalled it checked the whole install again deleted short cut made steam make a new one still no joy ran this D3D11Install_2010 still no joy still get d3d11.dll was not found
abm69 Jan 7, 2013 @ 7:50am 
and i try D3D11Install_2010 and it says DirectSD 11 is not supported on this version of windows iv got xp home
Showing 1-15 of 41 comments
< >
Per page: 15 30 50
Date Posted: Dec 28, 2012 @ 2:05pm
Posts: 41