Impire > General Discussions > Topic Details
SpookySquid Aug 12, 2013 @ 6:36pm
Is this mac compatible
Can this work for the mac I must know because my friend plans on getting it
Showing 1-2 of 2 comments
< >
UltraFlyingTaco (Banned) Aug 12, 2013 @ 6:48pm 
I believe it should say in the store page
Last edited by UltraFlyingTaco; Aug 12, 2013 @ 6:50pm
UltraFlyingTaco (Banned) Aug 12, 2013 @ 6:50pm 
Minimum:

OS:Windows XP/Vista/7
Processor:Intel® Core™2 Duo Processor E8400 3.0GHz or AMD Athlon 64 X2 6000+,
Memory:3 GB RAM
Graphics:NVIDIA® GeForce 8800 or ATI Radeon® HD3000 video card with 512MB of dedicated memory
DirectX®:9.0
Hard Drive:3 GB HD space
Sound:DirectX Compatible Soundcard
Other Requirements:Broadband Internet connection
Additional:3-button mouse, keyboard, speakers, Internet connection for multiplayer
Recommended:

Additional:3-button mouse, keyboard, speakers, Internet connection for multiplayer

Well, there's your answer
Showing 1-2 of 2 comments
< >
Per page: 15 30 50