daydr3am3r87 Feb 1, 2013 @ 9:57am
OMD 2 really low fps issue
Hi all

I've been playing OMD2 for quite some time now and after 30 minutes or so of gameplay the fps starts going down.
But it doesn't stay that way, it starts going up and down even in menu or spellbook.
I start playing with 70-80 FPS and in 30 minutes or so it goes to 10-15 and sometimes below 10.
I tried changing the settings without luck and I also reinstalled the video driver.
I checked the temperatures and it's not overheating since it bearably reaches 60 degrees in full load (45-50 in idle).
I only experienced something similar with Torchlight 2 but not like this.
This is happening every single time but especially in endless mode, after wave 25 or so, when the level gets crowdy.

Any way to fix this?

I'm running Windows 7 SP1 x64, all updates installed, on an Intel Core 2 Quad Q9300 2.50Ghz CPU, GeForce 285GTX 1GB VRAM DDR3 + 8 GB RAM.
All drivers are up to date.
Showing 1-10 of 10 comments
< >
Mr. OMG Feb 1, 2013 @ 11:03am 
Did you check the temperature of you VGA?
daydr3am3r87 Feb 2, 2013 @ 12:20am 
Yup, it barely reaches 60 degrees Celsius (140F) in full load.
Last edited by daydr3am3r87; Feb 2, 2013 @ 12:29am
√itamin ∃✘ Feb 2, 2013 @ 2:26am 
Try uninstalling the game and uninstalling Nvidia Physix, then reinstall the game and let the game install the Physix it includes/uses. I have a friends that was having trouble running Hamilton's Great Adventure because there was an issue with other versions of Physix and their compatibility but after he did this it fixed the issue.
Last edited by √itamin ∃✘; Feb 2, 2013 @ 2:27am
√itamin ∃✘ Feb 2, 2013 @ 2:48am 
You can aslo try this to unlock the 30 fps lock the game has:

You can customize some elements of Orcs Must Die! 2 by creating a user.cfg file and adding notes into it. Here are the instructions for how to properly set up a user.cfg file.
1. Navigate to C:\Program Files (x86)\Steam\steamapps\common\orcs must die 2\data\startup\ and create a text file called user.cfg. Ensure that you aren't creating a file called user.cfg.txt, as this is a common mistake in this step.
2. Edit user.cfg and add options from the list below to change your settings:

NoAlienFX Use this option to turn off the AlienFX lighting effects on Alienware Computers. This may also help with game launch issues that some Alienware users are experiencing.
–voice Be sure the minus sign is included or this command won’t work. Use this to completely disable in-game voice chat. Disabling the in-game voice chat will allow players to use the Steam voice chat instead, should they choose to.
HideCrosshair For players that want to play in 3D, this option will turn off the 2D reticule.
SwapOnBind Instead of unbinding a key when you set it in the game menus to a key that’s already in use, the game will swap with the key that was previously mapped.
-sound Completely disables game sounds
DoNotPostToLeaderboards Prevents your scores from posting to the leaderboards
EnableBloodMapToggle This allows you to toggle the blood map (at any time) using “L” key in-game or a custom keybind
ForceFPS=## This will force the game to use a desired number of frames per second. Replace ## with the desired number.

3. Save your user.cfg file (again, ensure that you're not saving it as user.cfg.txt) and relaunch Orcs Must Die! 2

Edit: Here is a link[www.mediafire.com] to an already made config file, just download it and place it in the correct location.
Last edited by √itamin ∃✘; Feb 2, 2013 @ 2:53am
daydr3am3r87 Feb 2, 2013 @ 3:21am 
@ExzoSSG I tried the PhysX trick and didn't help. I'll give it a try with user.cfg file.
daydr3am3r87 Feb 5, 2013 @ 3:16pm 
Tried everything. Didn't work out. Thanks anyway.
Cougarific Feb 5, 2013 @ 3:53pm 
Just for kicks, have you tried alt-tabbing out of the game then back in once it starts to slow down? I don't know why but that has worked for me in similar situations with other games.
daydr3am3r87 Feb 5, 2013 @ 4:14pm 
Done this too since first I thought it's the temperature so I wanted to check it out. It works but I get higher FPS for only 1-2 minutes than it drops back to 10-15 FPS.
Cougarific Feb 5, 2013 @ 7:13pm 
Isn't that odd though that it fixes it for a few minutes, even. That says memory allocation problems to me but I'm a novice on the troubleshooting side.
daydr3am3r87 Feb 6, 2013 @ 2:33am 
Hmm, didn't cross my mind but now you said it it does make sense, in a way.
Same thing goes for Torchlight 2. But there I don't start with 70 FPS so the drop is not so noticeble.
Any thoughts? I tried to get some answers on Robot Entertainment forums but no luck.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Feb 1, 2013 @ 9:57am
Posts: 10