Zack dela Rocha May 7, 2014 @ 7:58pm
Failed to start game (missing executable) Help! Please!
Hello Steam Community. Lately I've been having this problem where if I launch Orcs Must Die! 2 it pops up a small window saying 'Failed to start game (missing executable)'. I've tried almost everything there is to fix it but with no avail. I have this game on my windows 8 laptop and it works fine, but I'd rather play on this desktop since I use my laptop for mostly school related events rather than gaming. I will list what I've tried below, so if anyone knows the solution please, please help me out by listing it in the comment section. Thank you.

What I've Tried:
  • Vertified game cache
  • Uninstalled and Re-installed multiple times
  • Closed steam completely, deleted appcache, and opened steam back up
  • Check anti-virus software to see if it was in my quarintine (it wasn't)
  • Made sure the game launched in the same location through the app id
  • Installed Microsoft DX again and agian.


Thank you for your time.
Showing 1-6 of 6 comments
< >
Smeggit May 7, 2014 @ 8:09pm 
It's a long shot but you could try step 6 from here then verify the cache again:

https://support.steampowered.com/kb_article.php?ref=4595-wexn-6831
Cougarific May 7, 2014 @ 8:16pm 
You say it's not in your quarantine but you might try temporarily disabling your anti-virus completely then re-Verifying cache. (don't forget to re-activate your a-v when done)

Another player reported that their a-v was repeatedly deleting the executable on download.
Last edited by Cougarific; May 7, 2014 @ 8:18pm
Zack dela Rocha May 8, 2014 @ 6:50pm 
Before I say this, I'd like to thank you guys for attempting to help me out. I appreciate it. Anyway, I forgot to mention this in the main post but whenever I click on 'Vertify Game Cache' it does the vertifying process and when it finishes it say '2 files failed to validate and will be reacquired'. Then an update process begins to happen on Orcs Must Die! 2. However, it does not update at all. The process goes from 0% back to 'Update Required' on the game. If you guys know the solution to this please tell me. I apologize for bringing up a new problem. It's just that I'd like to play this game since I paid for it. Thanks everyone for helping me out.
Cougarific May 9, 2014 @ 2:37pm 
Yes again, it sounds like your anti-virus is blocking the .exe file. This has always been an issue for this game when using *certain* anti-virus programs.

Deactivate your A-V and try Verifying again.

FYI Verifying will always return "1 file failed to Validate and will be re-installed". If it returns more than 1 file missing, that's your problem right there. And it sounds like the file that's missing is the key .exe (executable) file.

Deactivate your Anti-Virus and try Verifying again.
Last edited by Cougarific; May 9, 2014 @ 2:38pm
Zack dela Rocha May 9, 2014 @ 10:47pm 
Nope Cougarific, It didn't work. I turned off all the AV that I'm almost certain I have. I guess I have to contact steam support and wait another 3 months for them to respone probably telling me to just vertify my game cache. But thank you for your effort, Cougarific.
TOOGAM May 10, 2014 @ 6:49am 
Tiny Hippo: I'm sorry to say, I have to agree with the other posters. Smeggit's hunch was obviously right, as the "verify cache" feature found an issue. And I would say the most likely problems are the following three: anti-malware software, malware software, or another computer problem (like bad RAM or a bad hard drive). However, currently those other computer problems I mentioned still seem less likely.
Do not read too much into Cougarific's statement about "more than 1 file missing". Even 1 file missing could cause exactly what you're experiencing.
I would need to suggest looking for more anti-malware software, or options in anti-malware software. I know that may sound particularly unlikely to help, but if that actually is the cause of the problem, then nothing else is likely to help. I'm reinforcing Cougarific's advice because it really does seem right, and I don't want you to waste even more time by pursuing a wrong path.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: May 7, 2014 @ 7:58pm
Posts: 6