Cities XL 2012 > 综合讨论 > 主题详情
ADJDred 2013年1月1日下午4:24
Anyone else having (Unknown error) when trying to start cities xl 2012
Anyone else having (Unknown error) when trying to start cities xl 2012?

I have installed it on my laptop (window s8) which should be fine to run the game or even get a useful error message.
正在显示第 1 - 11 条,共 11 条留言
< >
GPMedium 2013年1月4日上午11:39 
Yes I am having the same problem, just got a laptop with windows 8, it works on my windows 7 desktop pc. I think it is an issue with windows 8, I am going to try running in different compatibility modes.

-Edit-
So I know this will not help a lot, I did get it to work. I did not do any compatibility mode, I decided to try checking integrity of game cache. This showed that there were no issues, but after I did that I attempted to launch the game again and it worked. I know this was most likely not the solution and I am unsure how it launched but it did, so it defiantly does work on windows 8 (which is a good thing). Ill update if I figure out what I did differently.
最后由 GPMedium 编辑于; 2013年1月4日上午11:55
ADJDred 2013年1月4日下午1:45 
thanks for the update. I'll try the integrity test now and let you know how I get on.
ADJDred 2013年1月4日下午1:51 
run the test and it says everything is fine. tried running the game and it has the same issue as before. tried running as admin and setting compatability mode.
jolle 2013年1月5日上午5:43 
I have this problem.

When starting from Steam it says "Failed to start game (unknown error)"

If I start it manually in Explorer, it complains about the side by side configuration.

Validating integrity makes no difference.

Checking the system log, the problem seems to be that 'Microsoft.VC80.OpenMP,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.6195"' could not be found.

From what I can tell, this should be installed from the vcredist_x86.exe included with the game (and automatically run the first time you launch the game from Steam), but something is obviously amiss. Maybe it requires another redist which isn't included. In that case, only needs to figure out which one.
最后由 jolle 编辑于; 2013年1月5日上午5:44
jolle 2013年1月5日上午6:04 
An update, managed to get it working.

I manually installed the following redists:
http://www.microsoft.com/en-us/download/details.aspx?id=3387
http://www.microsoft.com/en-us/download/details.aspx?id=26347
http://www.microsoft.com/en-us/download/details.aspx?id=26368
(in all cases, the vcredist_x86.exe one)

Then rebooted.

Likely only one of them is really needed, but hard to say which one. I'd guess the middle one. But it doesn't really hurt to install all.
Kakashi Hatake 2013年1月6日下午11:20 
i don't have that promblen anymore i dont know why tho
ђ๏lltђยlђย 2013年1月7日下午3:19 
No, never had that problem.
NoThankYou 2013年1月9日下午1:28 
Would like to add to Jolle's above comments....

(I'm now running Windows 8 on my Alienware 4+yr old machine.)

I installed the 1 file from his first link, the bottom 2 files from his second link, the bottom 2 files from his third link and rebooted my machine. I attempted to run the game and it failed. I was able to move past the Steam Error Message and get a Cities XL startup Screen to appear.

Through Steam, I checked the integrity of my game files, 9 were missing/invalid. After downloading those files, the game ran fine.

Big THANKS to Jolle!!!!

jediewarrior 2013年5月22日下午10:18 
Hello, guys.. i am having this issue despite using windows 7. I deleted the game content and redownloaded and re installed. Stil nothing. I am running alienware mx18.. can u guys help
最后由 jediewarrior 编辑于; 2013年5月22日下午10:19
The doctor is in 2013年5月23日下午2:48 
normally try verify game cache

if that dont work manully reinstall prerequisites

if that dont work and you dont have any cities you want to hold on to

delete

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012

if that dont work

open the last log file in

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012\logs

and post the very last error
最后由 The doctor is in 编辑于; 2013年5月23日下午2:50
The doctor is in 2013年5月26日上午2:45 
引用自 jediewarrior
Hello, guys.. i am having this issue despite using windows 7. I deleted the game content and redownloaded and re installed. Stil nothing. I am running alienware mx18.. can u guys help


if its unknown error that people are getting then u need to do this

http://steamcommunity.com/app/201760/discussions/0/828925849428497654/#c828925849518210613

if its not unknown error or if the above does not work then do this

http://steamcommunity.com/app/201760/discussions/0/828925849428497654/#c810925398560962851
最后由 The doctor is in 编辑于; 2013年5月26日上午2:47
正在显示第 1 - 11 条,共 11 条留言
< >
每页显示数: 15 30 50