EverQuest II
EverQuest II > กระดานสนทนาทั่วไป > รายละเอียดกระทู้
himynameiswill 17 ส.ค. 2013 @ 2:26pm
Did any of you have trouble signing up?
Cant sign up for the game. Tried on username and it said for about half a second "cant be used" or something alond those lines (to fast to read) so i tried a new username and nothing appears. Just spamming the "Play Free" button in a vain attemp for it to start working
< >
กำลังแสดง 1-5 จาก 5 ความเห็น
2358 17 ส.ค. 2013 @ 4:09pm 
Try open the registering page with different browser. Having the same problem when using Firefox.
himynameiswill 17 ส.ค. 2013 @ 4:34pm 
It made an account, i verified it and it wont login on the client. Logged into their website and it said i have to change my pasword (no clue why) so i did the i logged back in and it told me to change it again. Poor
2358 19 ส.ค. 2013 @ 3:38am 
hmmm... sounds something wrong with the verifying system. maybe you can write to soe for help? wish you good luck on this.
whitenoise67 25 ก.ย. 2013 @ 12:14pm 
Tried to set up an account for my partner a few weeks ago and just gave up. Was having the same issue.. verified account via email, password and log-in was not being recognised, changed them (as prompted) still not recognised.. also,,ALL the names it was randomly suggesting to enter the game were in use..
I'm using firefox too.. didn't bother trying anything else, just gave up.
whitenoise67 29 ก.ย. 2013 @ 8:09pm 
I tried this again with IE and the same thing is happening.. just an endless loop of having to reset password. Won't let me sign in.
< >
กำลังแสดง 1-5 จาก 5 ความเห็น
ต่อหน้า: 15 30 50

EverQuest II > กระดานสนทนาทั่วไป > รายละเอียดกระทู้