EverQuest II > 综合讨论 > 主题详情
himynameiswill 2013年8月17日下午2:26
Did any of you have trouble signing up?
Cant sign up for the game. Tried on username and it said for about half a second "cant be used" or something alond those lines (to fast to read) so i tried a new username and nothing appears. Just spamming the "Play Free" button in a vain attemp for it to start working
正在显示第 1 - 5 条,共 5 条留言
< >
2358 2013年8月17日下午4:09 
Try open the registering page with different browser. Having the same problem when using Firefox.
himynameiswill 2013年8月17日下午4:34 
It made an account, i verified it and it wont login on the client. Logged into their website and it said i have to change my pasword (no clue why) so i did the i logged back in and it told me to change it again. Poor
2358 2013年8月19日上午3:38 
hmmm... sounds something wrong with the verifying system. maybe you can write to soe for help? wish you good luck on this.
whitenoise67 2013年9月25日下午12:14 
Tried to set up an account for my partner a few weeks ago and just gave up. Was having the same issue.. verified account via email, password and log-in was not being recognised, changed them (as prompted) still not recognised.. also,,ALL the names it was randomly suggesting to enter the game were in use..
I'm using firefox too.. didn't bother trying anything else, just gave up.
whitenoise67 2013年9月29日下午8:09 
I tried this again with IE and the same thing is happening.. just an endless loop of having to reset password. Won't let me sign in.
正在显示第 1 - 5 条,共 5 条留言
< >
每页显示数: 15 30 50

EverQuest II > 综合讨论 > 主题详情
发帖日期: 2013年8月17日下午2:26
帖子数: 5