EverQuest II > Algemene discussies > Details van topic
himynameiswill 17 aug 2013 om 2:26nm
Did any of you have trouble signing up?
Cant sign up for the game. Tried on username and it said for about half a second "cant be used" or something alond those lines (to fast to read) so i tried a new username and nothing appears. Just spamming the "Play Free" button in a vain attemp for it to start working
1-5 van 5 reacties weergegeven
< >
DIM2358 17 aug 2013 om 4:09nm 
Try open the registering page with different browser. Having the same problem when using Firefox.
himynameiswill 17 aug 2013 om 4:34nm 
It made an account, i verified it and it wont login on the client. Logged into their website and it said i have to change my pasword (no clue why) so i did the i logged back in and it told me to change it again. Poor
DIM2358 19 aug 2013 om 3:38vm 
hmmm... sounds something wrong with the verifying system. maybe you can write to soe for help? wish you good luck on this.
whitenoise67 25 sep 2013 om 12:14nm 
Tried to set up an account for my partner a few weeks ago and just gave up. Was having the same issue.. verified account via email, password and log-in was not being recognised, changed them (as prompted) still not recognised.. also,,ALL the names it was randomly suggesting to enter the game were in use..
I'm using firefox too.. didn't bother trying anything else, just gave up.
whitenoise67 29 sep 2013 om 8:09nm 
I tried this again with IE and the same thing is happening.. just an endless loop of having to reset password. Won't let me sign in.
1-5 van 5 reacties weergegeven
< >
Per pagina: 15 30 50