Cave Story+ > General Discussions > Topic Details
David Feb 7, 2013 @ 6:09am
Way forward from Plantation?
I can't get any further than Plantation. I've tried all the teleports and everything. I'm going round and round in circles and it's driving me mad. What do you do? I've tried everything and nothing is working! Please help.
Showing 1-7 of 7 comments
< >
Kuhaa Feb 7, 2013 @ 9:45am 
What have you done there so far? Have you, for example, tried talking to mimiga there? Someone might be up for some fishing... Sorry for being so vague, I don't want to spoil the fun of finding the rest out yourself. Also, at some point the minimap might prove useful. Good luck! Let us know if you still can't get any further.
David Feb 7, 2013 @ 1:10pm 
Thanks for replying. :)
I have searched high and low and making sure I haven't missed anything. I'll keep trying until I give up and ask for more help.
Cheers. :)
David Feb 7, 2013 @ 1:48pm 
I think I might restart the game from the very beginning. Maybe I've made a mistake somewhere and now it's impossible to go further? I'm just going round and round in circles. I have tried absolutely everything and looked everywhere, but I'm not finding anything new to advance me. It's sending me crazy! It's impossible now.
Kuhaa Feb 7, 2013 @ 2:30pm 
Talk to the Mimiga who was fishing in Mimiga Village back when you started the game. He's in a room next to the three patches with farming Mimiga and those annoying green things. After you've talked to him he leaves the room, and you can find him by the water at the lower part of the map. Talk to him again and he will give you a key which unlocks the door across the water.

I hope this helps you get started.
David Feb 7, 2013 @ 2:52pm 
I don't know where you mean. I have been round and round in circles everywhere but I'm not progressing. I have spent hour after hour in Plantation, Mimiga Village etc. but it's not getting me anywhere. Maybe I've done something wrong and there's a bug in the game?

The only thing I did "wrong" that I know about is riding on the back of the dragon over the clouds and got to a screen that said "end?". Then, second time round, I quit and said "no" to riding on the dragon. Since them I've been stuck.
Kuhaa Feb 7, 2013 @ 3:28pm 
Riding the dragon is the "bad ending" but it doesn't affect anything after you load the game again as it starts from the save before you said "Yes" to Kazuma. The room I'm talking about is the one with sleeping Mimiga, the fisherman and a one with glasses. Maybe this helps:
http://www.youtube.com/watch?v=CLk44tk7JDQ#t=6m28s

I had to put code tags because Steam insisted on embedding the video, in which case the timestamps wouldn't have worked.
David Feb 8, 2013 @ 5:00am 
Thanks for your help.
I found a "hidden" way into the door, below where the sprinklers are and now I have a mask. :)
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Feb 7, 2013 @ 6:09am
Posts: 7