Valen Oct 16, 2012 @ 3:07pm
Here are some Graphic .INI Tweaks
XCom Enemy Uknown uses the Unreal Engine so many of the .ini tweaks found in other games that are based on the Unreal Engine will work. Here are a few tweaks to improve the graphics that I have verified.

Find the XComEngine.ini (Make sure you save a backup copy incase you mess things up) located at: Documents > My games > XCOM - Enemy Unknown > Config

1) Increase Color & Lighting detail - Find " MaxProcBuildingLODColorTextureSize= " & " MaxProcBuildingLODLightingTextureSize= ".

Change to:

MaxProcBuildingLODColorTextureSize=2048
MaxProcBuildingLODLightingTextureSize=512

2) Unreal Engine supports texture streaming delay. Ever notice the the low resolution texures that are burry for a few seconds and then come into focus by changing into a higher resolution? The following will get rid of the streaming delay.

Find:

MipFadeInSpeed0=
MipFadeOutSpeed0=
MipFadeInSpeed1=
MipFadeOutSpeed1=

And change all the number values after the " = " to 0 (Zero)

3) Just some notes on AA and Depth of field. Xcom Enemy Unknown does not support AA in game, even though it has a AA setting in game. The Unreal Engine does not natively support AA. Xcom Enemy Unknown uses FXAA. I have not been able to really notice any difference at all in the 3 AA (FXAA) setting in game. This is because, most of the anti aliasing appears to controlled by simply having the Depth of field on in the XcomEngine.ini. If you turn off Depth of field from within the .ini file - you will notice Clearer & crisper graphics ingame. However, You will also get jagged lines regardless of your FXAA game settings.

I have not be able to find a way to simply turn off FXAA as it does not have a "OFF" option at all (Lowest setting is low). The reason I mention that is because if you could turn it off, there are other 3rd party Direct X software (Like injectSMAA) which do a far better job that FXAA.

Lastly, It may be possible to turn off Depth of Field and force AA through your graphic cards control panel - I have not tried it, But I'll put it out here for those who wish to try it.

To turn off Depth of Field. Go to your XComEngine.ini and find, " DepthOfField=True " and set it to false.

Have fun Tweaking !

Last edited by Valen; Oct 16, 2012 @ 3:20pm
Showing 1-13 of 13 comments
< >
Cougarific Oct 16, 2012 @ 3:14pm 
What does number 1). do?
Valen Oct 16, 2012 @ 3:17pm 
It increases the level of detail (LOD) for color and lighting. Sorry about that, I just updated the post to reflect what Number 1 does. 8)
Last edited by Valen; Oct 16, 2012 @ 3:21pm
Divine Cavalry Oct 16, 2012 @ 3:27pm 
Thanks
pyide_maybe Oct 20, 2012 @ 5:35pm 
So disabling Depth of Field also disables FXAA? If that's the only way to do it then so be it.

I hate games that don't let you disable FXAA. Sleeping Dogs was the last one where the lowest AA setting was Low rather than Off, hope it doesn't become a common thing.
Valen Oct 21, 2012 @ 7:21am 
Disabling Depth of field does not disable FXAA. However, there appears no way of disabling FXAA in this game. As setting FXAA to 0 (zero) or removing the .ini line for it causes major graphic problems. Having said that, FXAA in itself seems to do little if anything in this game. Depth of field does most of the Anti-alasing in this game - try it yourself - disable the depth of field - strange....
pyide_maybe Oct 21, 2012 @ 5:01pm 
It sure looks like DepthOfField=False does as it is the only AA method the game seems to use. However, disabling it also appears to get rid of other post-process shaders as well. The color correction is off, FXAA is gone, and obviously depth of field as well. Possibly something else?

I took some comparison shots, if FXAA were still on when DoF is off some textures and details would still be blurry because that is the big side effect of what it does and why it's the first thing I always disable in any PC game. Look closely at the thin man's hands and weapon in both shots, the puddle of water and bricks by the generator / light, my characters, and of course the edges with sharp and clear aliasing in one.

AA Low (FXAAQuality=1): http://cloud-2.steampowered.com/ugc/541815921128713792/4F8FA728663596B5D089D7DA29A12F26C2D78F02/

DepthOfField=False: http://cloud-2.steampowered.com/ugc/541815921128904066/1AF6F617EB05DFC60D2FBC368C7F356F9A3536B8/

I've never seen any form of FXAA where minor details are that defined. Jpeg compression doesn't help though, it's definitely more noticeable in real time in game.

Until they add an option to disable only FXAA and keep the other post-process effects (which you know they won't), I'll just have keep AA on high which lessens the blur and sit far back from the screen so my eyes don't bleed from trying to focus on slightly blurry images for long sessions. It's not really as bad in XCOM as it can be in other games because of the already low fidelity style and assets, and you are rarely up close looking at the minor details anyway from the overhead view.
Last edited by pyide_maybe; Oct 21, 2012 @ 5:04pm
pyide_maybe Oct 21, 2012 @ 5:20pm 
And there is a difference between the three anti-aliasing settings, it's subtle compared to the previous on / off comparison but it's there.

AA High (FXAAQuality=6):
http://cloud.steampowered.com/ugc/541815921128715139/ECA32E88447D4A448C01C1D3BB916593463D6C26/

AA Med (FXAAQuality=4):
http://cloud-2.steampowered.com/ugc/541815921128711646/3CED94110701723E2555046F988E77EAEE7DC6BD/

AA Low (FXAAQuality=1):
http://cloud-2.steampowered.com/ugc/541815921128713792/4F8FA728663596B5D089D7DA29A12F26C2D78F02/

Yet there's no difference at all with the three AA settings when depth of field disabled, so it really does appear to disable the post-process FXAA shader along with some other stuff.

One thing I noticed while looking through the configs of another recent UE3 game, Borderlands 2, is that its engine.ini has an FXAA=False / True toggle. Adding it to XCOM does nothing, but it should be that easy. It's weird how they tied certain post-process effects to others, though it makes sense on consoles where that kind of customization never exists in the first place. Also strange how AmbientOcclusion=False will crash the game when a map loads.
Valen Oct 22, 2012 @ 1:23pm 
Hey Pyide - thanks for the feedback. It will help the community 8)
pyide_maybe Oct 22, 2012 @ 4:29pm 
Another annoyance from the forced FXAA is the slightly blurry text in the floating 3D menus and text dialogues such as those seen around the base. Anything that's not a true 2D foreground UI element, the actual 2D UI & HUD is unaffected.

It's subtle but it's enough to be fatiguing to read. The long post-research text entries are the worst for me, but even just going through the build menu or equipping stuff for your squad can be hard on the eyes after a while. All that stuff is blurrier than it otherwise should be because of the post-process AA method.


Last edited by pyide_maybe; Oct 22, 2012 @ 6:24pm
IndigoAK Oct 24, 2012 @ 3:41pm 
Does the LOD tweak even work? (ie. can somebody provide screenshots)

In my experience, tweaking LOD settings rarely makes any noticeable difference and just because one game may see a difference with it tweaked doesn't mean all of them will. Developers often make modifications to whatever version of UE3 they're using. For instance, most UE3 games have a DX10 toggle in their .ini files somewhere and people swear to the high heavens that it makes a difference, when in reality there's yet to be a game released (that I know of) that actually changes based on what that toggle says.
Seimalau Oct 24, 2012 @ 3:56pm 
Thanks!
Valen Oct 27, 2012 @ 7:07am 
Most UE3 games don't support DX10 even if their is a .ini setting for it.
Shrcker Nov 6, 2013 @ 6:39pm 
I tried turning off Depth of Field, but now everytime I go through a cinematic, the screen freezes and I get these black bars going through the screen, it then either freezes the game entirely or lets me click the button to exit the Skyranger. Is this a problem with my computer, or did I do something unintentional?
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Oct 16, 2012 @ 3:07pm
Posts: 13