XCOM: Enemy Unknown

XCOM: Enemy Unknown

View Stats:
*IMPORTANT* REAL Stutter Fix (PIN THIS)
First off, I rarely post anything, but after reading about this in UE3 based games over and over again and having a unique knowledge of the unreal engine (I've playtested games based on all of them) I could sit idle no more.

Ok, so you have read countless drobes of stuff on how to fix stutter or hitching or frame lag or whatever you want to call it, and you really can't find something that "works" period. Search no more, you have found IT.

READ COMPLETELY

This guide will not feature technical explanations as to why the settings work. It is writ for the everyday gamer. It is important to note that the UE3 engine was designed with consoles in mind and needs to be optimized for PC use. YOU MUST INCLUDE ALL CHANGES. Do not attempt unless you have a decent knowledge of what you are doing(and how to undo it). This will not effect the ablilty to play online and does not fall outside the guidelines of VAC.

And yes you may have seen some of these settings and tried some of them but they MUST all be done together for this to work properly because many settings affect the timing of other settings since this is a streaming based engine. TRY IT this way 1st. plz. give it a chance.

This WILL NOT fix choppy bink video playback as that is plugin based and not engine based. That is a different animal altogether (its very poorly coded for multi-core cpus)

THIS FIX WORKS FOR ALL UE3 BASED GAMES.(well tested)

I need to take a moment to explain that this will fix the kind of stutter that you get even on med to high-end hardware commonly called load/frame hitching. This is where your getting great Frames Per Sec (as reported by fraps or afterburner) but it "looks" choppy. Poor performace (I.E. running a game at settings you know your HW can't run well) will not see a serious decrease in hitching, though it will still help a fair bit. You can really tell the difference if you run with vsync ON and compare BEFORE FIX/AFTER FIX smoothness. It is very, very obvious. Anyhow....

ALL GAMES MUST HAVE COMPLETED FIRST RUN. (1 startup then exit)

1st Goto \ users \ yournamehere \ documents \ my games \ gamename \ ...... \ config.
(Note: EA games sometimes use "EA Games" instead of My Games)
Make a Backup of the "engine" ini file just in case you need it.

2nd Open the "engine" ini file in notepad (or your text ed of choice) Find and change the following lines ( just use ctrl-f ) taking care to match the settings to your system where noted. Also some of these settings you may not have to change IF they already match what is given.

Here they are: (REMEMBER, READ CAREFULLY, MATCH EXACTLY)
"*"=setting
"bUseTextureStreaming=True" (these are default for most but not all UE3 games)
"bUseBackgroundLevelStreaming=True"
"MipFadeInSpeed0=0" (these even out mipmap loads and draw time)
"MipFadeOutSpeed0=0"
"MipFadeInSpeed1=0"
"MipFadeOutSpeed1=0"
"PhysXGpuHeapSize=64" (these balance physx calls even on cpu based physx titles)
"PhysXMeshCacheSize=16"
"bSmoothFrameRate=TRUE" (this really does need to be on, ignore what you've read)
"MinSmoothedFrameRate=30" (keep these right here. setting higher/lower does no good)
"MaxSmoothedFrameRate=400"
"bInitializeShadersOnDemand=True" (reduces overall shader batch call size)
"DisableATITextureFilterOptimizationChecks=False" (driver based opt is MUCH faster)
"UseMinimalNVIDIADriverShaderOptimization=False" (same here)
"PoolSize=256" or (vidmem/poolsize exmpl: 512/128, 1024/256, etc, DO NOT exceed 768)
"bAllowMultiThreadedShaderCompile=True" (should already be on by default)
"ThreadedShaderCompileThreshold=4" (formulate like this: # of cpu-cores (not threads) -2)
"OnlyStreamInTextures=True" (reduces overall texture batch call size)

Check for multiple instances of these settings within this file as some games have them listed twice and you must change both (I.E Xcom:Enemy Unkown)

Now save the file, then right click it, choose properties and then set it to "read-only".
Launch your game, choose reset to defaults under that games graphics settings, then set them up how you want. These settings get saved to your profile file for that game and use the engine ini as a base. They are not saved to the ini file therefore it wont matter that it is read-only. However there are a few rare exceptions (SEE NOTE BELOW)

THAT'S IT.

All other settings in the file should be left at there defaults
(Yes, even "SizeOfPermanentObjectPool". FYI This can hurt performance if set different from defaults because it can actually increase frame call time if set incorrectly)

All changes asume that you have steam cloud sync on. If not, changes you make may be overwritten if you turn on cloudsync after the fact and may need to be re-done.

(SPECIAL NOTE) Some UE based game like BatmanAA or AC need to be configured how you want it 1st THEN do the fix minus the reset defaults part. You will also need to modify the "userengine" ini file in the same folder as the one above to match any relevent settings.

If you have done everything correctly YOU WILL NOTICE IT. Unlike other "fixes" the performance of this one will be VERY obvious, Especially for ATI/AMD owners. In fact the title screen loading for Dishonored is a dead giveaway (which is why I put this in here)

Special thanks to:
xbit411, lawn_dartmouth, z1g1t and the guys at the beta labs at AMD for help w/this.

Peace. MG.
< >
Showing 1-15 of 117 comments
just for lulz Nov 17, 2013 @ 7:57am 
awesome. XCOM runs very smooth after these changes. thank you!
The Hoff Jan 2, 2014 @ 5:11pm 
I was so sure this list of instructions wouldn't work for my scroll stuttering issues, but this fix works beautifully. I have a top end PC and every game runs as smooth as butter apart from XCOM and the expansion. I always had a slight scroll stutter and nothing I tried could fix it.
After applying these simple edits to both files in XCOM and the ENEMY WITHIN, it is like a new game.
If anyone is having any stuttering issues (even with a decent rig) I highly recommend this lifesaving fix. Kudos to the OP :)
Dorok Jan 2, 2014 @ 5:22pm 
I don't have any issue with that this game, but I wonder for some UE based games.

Some questions :
- "formulate like this: # of cpu-cores (not threads) -2" So 4 means there's 6 core?
- "vidmem/poolsize exmpl: 512/128, 1024/256, etc, DO NOT exceed 768". Can you reformulate that?
EDIT: Ok on second point you suggest allocate 25% of vram size.
Last edited by Dorok; Jan 2, 2014 @ 5:24pm
HyperBluPanda Jan 28, 2014 @ 9:00pm 
I couldn't find the first one and i looked everywhere any ideas?
mono Apr 8, 2014 @ 12:23pm 
I was 100% convinced this wouldn't work, mainly because I've played XCOM:EW without those issues before on this box, no idea why they suddenly popped up. But ... it worked like a charm, so many thanks to M.S.G.D
Kargath Apr 16, 2014 @ 3:48pm 
This helped me too. It's not perfect but scrolling around a map is visibly smoother now on a powerful system. I've had to tweak settings in at least 10 Unreal Engine games to eliminate similar problems. Why don't developers do it right in the first place?

Now if only RAD (Bink) would do something about the stuttering cutscenes that are present in so many games.
Nicholas Steel Jun 16, 2014 @ 10:30am 
Any version of this that simultaneously turns off the "texture fade in" effect? Kinda annoying when a level loads or some such and watching the textures on everything rapidly transition from butt ugly to good instead of just being good from the beginning.

I also only have a weird stutter when watching in-engine cutscenes, everything else like gameplay, is perfectly smooth as butter.

Edit: Enemy Unknown, not the expansion. I'm not up to that yet ^_^"
Last edited by Nicholas Steel; Jun 16, 2014 @ 10:31am
CrunchyBiscuit Jun 26, 2014 @ 9:08pm 
Dude, these tweaks actually really work! None of those poolsize-hysteresis-something-tweaks ever helped with the graphical stutters, but these really do!! :)))

Excellent job posting this, you could help out other people with similar issues on other game forums too, as this fix is not just limited to this game, but can be applied to many UE3-based games. Indeed, the intro menu from dishonored is a good indicator. It still stutters though, but not nearly as bad as before.

Is this topic pinned already? It should be.

Setting "bSmoothFrameRate=TRUE" isn't required however, tweaks work just fine with it set to false. I might try eliminating the tweaks one by one to see which ones aren't needed, there might be others, but I'm gonna be too busy playing some games I refused to play before because of the stutters :)

Processor: AMD Phenom II x4 3800MHz
RAM: 4GB Kingston HyperX 1333MHz 7-7-7-20
Videocard: AMD Radeon HD6950 2GB
Motherboard: Asus M4A88T-M
Sound: Onboard VIA HD Audio
Operating System: Windows 7 Ultimate 64-bit
Last edited by CrunchyBiscuit; Jun 26, 2014 @ 9:10pm
mrWizard Jul 23, 2014 @ 2:13pm 
For anyone still having stutter, try to disable v-sync and/or the "smooth framrate" option. Solved it for me.
LitterimMezuzah Aug 19, 2014 @ 12:01pm 
this worked, temporarily. For some reason now, it's back to the old ways of stuttering every other move and when aliens appear. Checked the engine (both of them) and all the changes are still there. so confused!
Afreakan Engineer Aug 24, 2014 @ 8:12pm 
Thank you M.G.S.D!!! I was a bit skeptical at first, but you were spot-on - and you've made Dishonored a FAR better game experience for me! I has having terrible problems with motion jerkiness, but this smoothed things out considerably! It's still not perfect, but it's no longer a major annoyance.

EVGA MB and Video Cards
Core i7 920 CPU @ 3.35 Ghz
24 GBs DDR3 2.5Ghz
Dual nVidia GeForce GTX 560 Ti SLI
Dell PERC H700 with 2 x 240GB SSDs and 4 x 3TB Seagate HDDs
Win 7 Ultimate x64

ugli Oct 19, 2014 @ 5:42am 
damn. didn't work for me. I have constant stuttering with sound on XCOM. Everytime you reload, shoot etc. There is a slight pause/stutter before the sounds starts. None of the edits to the engine.ini did anything to this :/
Fumbles Oct 22, 2014 @ 1:57pm 
I tried these (and other) fixes to no avail - the game kept stuttering. Then I tried something other people had reported - I was sharing my internet connection from my smartphone (usb tethering) and when I switched to a "normal" modem, ta-da, the game was suddenly stutter free. I don't know the specifics as to why this causes the problem, but apparently it does or at least is one of the many causes. If you use tethering I would suggest trying some other way to connect or trying to play in offline-mode and see if that fixes the issue.
DaVince Nov 28, 2014 @ 3:16pm 
This worked nicely for Tower Of Guns, and got me an increase of 15-20 FPS in general. When things get hectic, it'll still slow down a lot, and it still seems to be using only 2 CPUs, but I think this is probably an issue with the code and not the renderer.
F|H Fresi Dec 30, 2014 @ 10:16am 
Ty so much for this one, faild first time as I forgot to search for every instence of these etings, but got it working on the second go <3

back to playing a great game
< >
Showing 1-15 of 117 comments
Per page: 15 30 50