A Game of Dwarves > General > Topic Details
Wolvenheart Nov 1, 2012 @ 3:54pm
Requires a Graphics Card that supports at least feature level: DX10_0
Am I missing something. I have an ATI Radeon HD 5800 which supports DX11 and all lower versions. I've updated my drivers but it still says this error message.
Showing 1-3 of 3 comments
< >
Company of Horrors Nov 1, 2012 @ 4:02pm 
Have you asked on the PDX bugs forum?
jevaude Feb 12, 2013 @ 11:39pm 
I'm having this same problem and I'd really like a fix for it. I'm highly upset that I paid money for this game yet I can't play it! I have Windows * Pro, and Direct X 11 I too have also installed, uninstalled and re-installed my drivers, to no avail. I'd delete the game from my Steam library to re-download it but I'm scare I'd have to pay for it again.

It would be really nice if some Steam Techs can get on this for us.
Wolvenheart Feb 15, 2013 @ 5:12am 
once bought a game doesn't just dissapear from your steam library unless you've had it refunded.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50