A Game of Dwarves > General > Topic Details
lonely Oct 28, 2012 @ 8:29am
Hotfix for Camera
Post here if you still have issues with the camera being stuck after loading a game where the camera previously was broken.

Otherwise, Enjoy the fix!
Last edited by lonely; Oct 28, 2012 @ 8:31am
Showing 1-15 of 20 comments
< >
Walincas Oct 28, 2012 @ 9:05am 
Have had no trouble with the camera so far, seems to be working as intended now, thanks for the fix :)
Freezeypop Oct 28, 2012 @ 9:39am 
ts been working so far thanks for such a quick fix
Method * e S Oct 28, 2012 @ 9:45am 
My game has been fixed! thanks a lot for the hard work and quick patch!
Tairgire Oct 28, 2012 @ 10:13am 
It worked perfectly this time. Thank you so much!
Lillarpy  [developer] Oct 28, 2012 @ 10:54am 
Second time is the charm! Nice to hear it is working out for everyone so far :)
C2 Oct 28, 2012 @ 2:20pm 
It is still breaking ocasionaly, but it fixes now
City Builder Oct 28, 2012 @ 2:55pm 
For me it's breaking the camera zoom hot keys. If I did not have a mouse with a scroll wheel I'd be screwed and could not zoom in or out.

Let me explain...

I use the hot key Z to zoom all the way in, then I press and hold my X key to zoom back out but it does not work. I use my mouse wheel to just 'nudge' the camera view up from the closest zoom point and then the X key will zoom all the way out.

Now my camera is zoomed all the way out, I press my Z key to zoom back in and it does not work. I again have to use my mouse wheel to zoom in just the tiniest of amounts and then the Z hot key will work again and let me zoom back in.

This happens every time that I use the hot keys to zoom in and out TO THE CLOSEST AND FURTHEST ZOOM LEVELS, I've got to kind of reset them by using the mouse wheel to nudge the camera up off the bottom (closest zoom) and again when it's zoomed all the way out.

So for this aspect of it, it's still a broken camera with regards to hot keys
Last edited by City Builder; Oct 28, 2012 @ 2:56pm
[Xfire] WonderGamer Jan 5, 2013 @ 7:27pm 
Same issue. Camera is almost level with the environment in the game I am TRYING to play. Decided there was no reason in continuing to play it until the issue was fixed (I'm getting tired of having to restart the game whenever this happens, I haven't finished a single game yet other than The Brickyard). I'm searching for other alternatives (cheats, hacks, console commands, add-on files) in the mean time until an official fix is released.

EDIT: I found this[forum.paradoxplaza.com], but it doesn't appears to actually do anything.
Last edited by [Xfire] WonderGamer; Jan 5, 2013 @ 8:22pm
Lost in Space Jan 11, 2013 @ 1:43am 
Same issue. On campaign at a certain quest, the map gets horizontal and I can't place 'dig' indicators or get perspective at all. It worked fine up till the final 'dig deeper' quest came up. Have reloaded game several times; same result. Other completed campaign quests work fine.
shadowxsoul Feb 8, 2013 @ 11:59pm 
I just downloaded this game from steam thursday, and the camera has been slowing getting lower and lower. Now, its essentially horizontal with the ground, making my game unplayable. Reloading does NOT fix it, nor does fiddling with the camera controls. I dont understand why there is no control for changing the angle of the camera up and down, an option like that may actually fix this problem.
Xerkis Feb 17, 2013 @ 1:22pm 
The mouse 3 button (or pressing the mouse wheel in my case) does control the camera angle up and down.
This doesn't fix your issues?
shadowxsoul Feb 18, 2013 @ 2:22am 
The mousewheel for me does nothing but make the camera zoom in and out, it doesnt angle the camera vertically. Even if is start a new game it doesn't do anything.
[Xfire] WonderGamer Feb 21, 2013 @ 6:38pm 
He was saying to hold down the mouse wheel & move the mouse up & down. This doesn't work for me, although if I move it side to side while holding down the mouse wheel, it will cause the camera to rotate. Doesn't effect the vertical angle, however.
Xerkis Feb 22, 2013 @ 4:20am 
Thanks for clarifying for me WonderGamer. That is what I mean. You “click” the mouse wheel and hold it in then move the mouse around.
What about using the “free look” hotkey. By default it is set as the left shift key. Hold that down and move the mouse. “Should” control the camera in all directions.
shadowxsoul Feb 23, 2013 @ 12:33am 
No, neither of those options work either. I can rotate the came side-to-side using either of those methods, but it wont move up and down.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50