A Game of Dwarves > General > Topic Details
lonely Oct 23, 2012 @ 1:56pm
[STICKY] Please post your bugs and crashes in Technical Support Forum
Last edited by lonely; Oct 23, 2012 @ 1:56pm
Showing 1-15 of 108 comments
< >
Teflon Oct 23, 2012 @ 2:25pm 
For some reason my resource information dissapears sometimes, such as, gold, and stone, i tried restarting the game and still cant get it to show my stone resource.
Xerkis Oct 23, 2012 @ 5:15pm 
Originally posted by Slayv:
For some reason my resource information dissapears sometimes, such as, gold, and stone, i tried restarting the game and still cant get it to show my stone resource.
You might not have any left. If it reaches 0 the icon will go away.
Burnzy Oct 23, 2012 @ 5:53pm 
I have just downloaded the game and when I start the game the screen comes up and stays black. After a few seconds it says the application must exit immediately and it crashes. Is there anything I can do to fix this?
Thorwaldsson  [developer] Oct 23, 2012 @ 6:04pm 
@Burnzy

http://steamcommunity.com/app/200370/discussions/1/864949483126136280/

Take look in this thread :)

//Thorwaldsson
Burnzy Oct 23, 2012 @ 6:07pm 
scripts/boot.lua:27: attempt to index global 'Steam' (a nil value)
stack traceback:
[1] scripts/boot.lua:27:in function <scripts/boot.lua:6>

local_variables:
--- CPU
CPU: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
Vendor: GenuineIntel
Logical processors: 8
Family: 0:6, Model: 3:10
Type: 0, Stepping: 9
Features: SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
Feature bits:
EBX: 00000111 00010000 00001000 00000000
ECX: 01111111 10111010 11100011 10111111
EDX: 10111111 11101011 11111011 11111111
--- OS
Windows version 6.1 build 7601, SP1.0, 64 bit
Windows 7, Service Pack 1
--- Graphics
Graphics card: Intel(R) HD Graphics 4000 (DirectX 11.0)
--- Sound
Sound card: Speakers (Sound Blaster Recon3Di) (48000 Hz, 2 channels)
Speakers: front.left front.right
--- Network
Network interface: Microsoft Virtual WiFi Miniport Adapter #2 (IPv4, IPv6)
Network interface: Microsoft Virtual WiFi Miniport Adapter (IPv4, IPv6)
Network interface: Intel(R) Centrino(R) Wireless-N 2230 (IPv4, IPv6)
Network interface: Bluetooth Device (Personal Area Network) (IPv4, IPv6)
Network interface: Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20) (IPv4, IPv6)
Network interface: Teredo Tunneling Pseudo-Interface (IPv6)
Network interface: Microsoft ISATAP Adapter (IPv6)
Network interface: Microsoft ISATAP Adapter #2 (IPv6)
Network interface: Microsoft ISATAP Adapter #3 (IPv6)
Network interface: Microsoft ISATAP Adapter #4 (IPv6)
--- Input
Input device: Mouse (18.1): Mouse
Input device: Keyboard (19.4): Keyboard
Phil Oct 24, 2012 @ 12:30am 
scripts/boot.lua:27: attempt to index global 'Steam' (a nil value)
stack traceback:
[1] scripts/boot.lua:27:in function <scripts/boot.lua:6>

local_variables:
--- CPU
CPU: AMD Phenom(tm) II X4 970 Processor
Vendor: AuthenticAMD
Logical processors: 4
Family: 1:15, Model: 0:4
Type: 0, Stepping: 3
Features: SSE SSE2 SSE3
Feature bits:
EBX: 00000001 00000100 00001000 00000000
ECX: 00000000 10000000 00100000 00001001
EDX: 00010111 10001011 11111011 11111111
--- OS
Windows version 6.1 build 7600, 64 bit
Windows 7
--- Graphics
Graphics card: NVIDIA GeForce 9800 GT (DirectX 10.0)
--- Sound
Sound card: Speakers (Realtek High Definition Audio) (48000 Hz, 2 channels)
Speakers: front.left front.right
Sound card: Realtek Digital Output(Optical) (Realtek High Definition Audio) (48000 Hz, 2 channels)
Speakers: front.left front.right
Sound card: Speakers (2- Plantronics GameCom 780) (44100 Hz, 6 channels)
Speakers: front.left front.right front.center low.frequency side.left side.right
Sound card: Realtek Digital Output (Realtek High Definition Audio) (48000 Hz, 2 channels)
Speakers: front.left front.right
Sound card: Audials Sound Capturing (Audials Sound Capturing) (44100 Hz, 2 channels)
Speakers: front.left front.right
--- Network
Network interface: Realtek PCIe GBE Family Controller (IPv4, IPv6)
Network interface: Microsoft ISATAP Adapter (IPv6)
Network interface: Teredo Tunneling Pseudo-Interface (IPv6)
--- Input
Input device: Mouse (18.1): Mouse
Input device: Keyboard (19.4): Keyboard
Input device: Generic (17.0): Razer Gaming Device
Input device: Generic (17.0): HP Link-5 Micro Receiver
Input device: Generic (17.0): Plantronics GameCom 780
OreGuy Oct 24, 2012 @ 1:00pm 
I've encountered some camera glitches a few times while playing, sometimes the game will,
Make the "q" and "e" keys very sensitive.
Zoom in past the maximum zoom, while zoom controls do nothing.
Lock the camera at an odd angle and will disable camera rotation controls.

Just now the camera fixed itself at about 0 degrees so it's almost flat, "q, e, and Rshift" usually only pan the camera and don't rotate it, in other words I can only look from the south towards the north at a low angle. Mousewheel does nothing. Sometimes clicking the class buttons brings you to a dwarf, or it might launch the camera miles away from the dwarf base.

http://imageshack.us/a/img547/5269/612054368.png
http://imageshack.us/a/img211/3482/701932610.png
http://imageshack.us/a/img22/8645/190416015.png
http://www.youtube.com/watch?v=sv8iT1P2iyg&feature=youtu.be

It's a great game, reminds me of that game evil genius, I dont mind a few glitches


Windows 7, 2.2ghz i7 2670qm intel, 6gb ram, 64bit
Last edited by OreGuy; Oct 24, 2012 @ 1:06pm
roma5310 Oct 24, 2012 @ 2:56pm 
I have a few glitches or bugs . Like
mobs hit my generators thru walls i put up to defend them .
traps not working .
ranged class does not kite or stay at ranged on melee mobs . they just stand there and get face ♥♥♥♥♥.
Thorwaldsson  [developer] Oct 24, 2012 @ 3:18pm 
Thanks for your feedback guys, I'll be sure to have these bugs brought to the exterminator :)

//Thorwaldsson
drewsuser Oct 24, 2012 @ 3:26pm 
I have a fix for SOME startup crashes. Not quite sure if those were still going on but I have a fix that worked for me. Go to %appdata% click on Zeal Game Studio then click a game of dwarves there should be a user_settings open it with notepad. Find falsefullscreen_output change the false in falsefullscreen to truefullscreen_output. It should work. I think there is a way once your in the game to default this. If there isn't just repeat what I said every time you want to pley.
[SVFT] ☭Kruor☭ Oct 24, 2012 @ 10:26pm 
Okay sometimes the camera 'focal point' can bug out and be displaced. Im fairly sure this happened when i was moving the camera around whilst trying to place/rotate an object. Regardless, the effect is that now the focal point is significantly moved.

Eg: I hit F1 to centre in on my Prince and the camera moves like 2x map length out and when i rotate the view around, it pivots on a point beyond the map. Hope im describing this correctly.. Anyway there is no way to 'reset camera' which would be an amazing feature.
Fuzzball Oct 25, 2012 @ 11:12am 
Found 3 minor issues.

1. I had a perfectly accessable piece of marble which my dwarves refused to dig out.
2. I had a 2 tile gnome table with 1 half stuck in the wall.
3. I had a room show up when I dug out a ?? area that wasn't connected to the main room. I was unable to reach it because it was incased in Undiggium.

Hope this helps.
Last edited by Fuzzball; Oct 25, 2012 @ 11:12am
Freezeypop Oct 25, 2012 @ 7:31pm 
cammera freezes. needs a bit of tweaking
drdrei18 Oct 26, 2012 @ 2:57am 
OMG Dungeon Keeper anyone. Best 9 Dolllars i have EVER spent! I adore this game, BUT, there are some serious Camera Glitch Tweaks that need to be done, i hate not being able to control my zoom, i am not sure how it happens but be warned that it will. Please Fix only thing that has really hurt the amazing dwarfing.
lonely Oct 26, 2012 @ 6:55am 
We will look more at the camera. It will take a week or so thought as we wan't to do it good.
Last edited by lonely; Oct 26, 2012 @ 6:56am
Showing 1-15 of 108 comments
< >
Per page: 15 30 50