Batman: Arkham City GOTY

Batman: Arkham City GOTY

View Stats:
Revisor Nov 26, 2012 @ 11:56am
Crash on startup solved by disabling PhysX
Hello,
like many I couldn't start Arkham City - it crashed right on startup. I solved it by disabling the HW acceleration for PhysX.
How?

Open your Steam library.
Right Click "Batman: Arkham City GOTY"
Choose "Configure PC Settings" (Why it's hidden here, I have no clue)
Choose "Settings"
Scroll down to PhysX and turn the HW acceleration off

As a sidenote, the useless layers of DRM are astonishing. GFWL in Securom in Steam. No wonder so many things can go wrong.
< >
Showing 1-12 of 12 comments
Entenjongleur Nov 28, 2012 @ 8:36pm 
Thank you very much your advise helped me a lot. Your solution worked great for me.
Trun Dec 1, 2012 @ 2:51pm 
I did this fix and got a black screen when starting..
azayomi Dec 1, 2012 @ 3:44pm 
I have a AMD Radeon Card. My PhysX is disabaled permanently. I don't have PhysX. I can't get it to load past the desktop Windows 7 or 8 fresh installs. I have Games For Windows Live loaded and working!
Sir SmeggTits IV Jul 17, 2013 @ 1:19pm 
I'm sorry but when i right click there is no 'Configure PC Settings', can anyone help please? I would love to do this as i have been waiting so long to play this game.
Kestrel Aug 15, 2013 @ 8:28am 
If it is the same as with Arkham Asylum, copying the dlls from the physx\common directory to the /binaries and setting nvidia to use GPU for physics instead of "auto" should make it work
Idontknow Nov 9, 2013 @ 1:04pm 
guys I don't have configure pc settings((
Big Pink Bunny Dec 28, 2014 @ 10:43am 
I make this one:
1) delete Physix from my PC
2) start the game, game installed Physix and then starting without problem
elfx May 22 @ 5:55am 
Disabling PhysX worked just fine. Thanks.
No need to disable PhysX. Open the nVidia Control panel and change the PhysX settings from automatic to your nVidia card. It's defaulting to the wrong card and causing the crash. I also recommend opening the GeForce Experience control panel and optimizing the settings for the game. It will run better.
Buck May 24 @ 1:35pm 
Jesus this is the worst grave dig I've ever seen.

You should really not take ancient threads at face value man. things would have changed since then and better workarounds could have been found. Most crashes are resolved by simply upgrading drivers. that's all.
Last edited by Buck; May 24 @ 1:36pm
The 6th grade called. They want you to go back to class. Don't assume everyone posting on an old thread is a novice just because you think new threads should be created for the same issue just because it's old. Drivers were updated as a first step and that didn't resolve the issue.
ivobrown Jul 21 @ 1:56am 
Originally posted by Kronos1357:
Deleting the file at
MacintoshHD/Users/[username]/Library/Caches/com.feralinteractive.bmac/com.plausiblelabs.crashreporter.data
worked.
This worked for me
< >
Showing 1-12 of 12 comments
Per page: 15 30 50