samwonderuk Dec 30, 2012 @ 8:58am
BATMAN ARKHAM CITY: DX11 FIX
i have noticed how many people are complaining of framedrop (i was too lol) and i found this link.

http://www.evga.com/forums/tm.aspx?m=1509605&mpage=1

i was having issues now it runs fine, now playing in at 55-60fps 1080p ,msaa x4,all games setting on extreme,with dx11 on with tessalation on normal
remember to back up any files you change but hope this might help some of you :D
Showing 1-15 of 19 comments
< >
id Jan 26, 2013 @ 8:22pm 
This metod don't work for steam version. Actually, there is no bmgame or bmengine on steam version. Even if you delete the equivalents (defaultgame, defaultengine), the game will report that files are missing on start and will close. The games runs at high fps here even on dx11 (gtx 670 here) but the stutter issue continues. Some people says that if you round your camera 360º the game will run normally until you "see" anything new. This really can help, but it's not a fix, only a amend.... Otherwise, if a really large amount of people sue WB because their misleading advertising (they was making a fus because dx11, no?), they may have judicial obligation to make a decent fix (considering you win). I think they will simply refund you. We can apply this on mass effect too for having xbox controller suport on the xbox360 (duh) and not on PC (where microsoft officialy suport the very same controller) (hum... okay, maybe not in this case hehehehe)

For instance, I see this very same problem on some unreal games like alice (very very little through, it's more like a insconstant fps.... and, hey! I have a 670 + 460se for physx! WTH!!!). both games limits the resourses somehow causing us this headache....

conclusion: nobudy likes to optmise games on PC because there is always a more potent hardware... because of this we need at least 2x hardware compared to a ps3 (400 gFLOPS) to run games on same settings.... (or you think you can run ps3 games (PC version) on an 8800 gt at 720p?)

Beleave me: you computer is a really fast machine that is colossally subused.... by everyone! try to run youtube on a not so old computer like p4 or athlon XP and see what happens... (those pcs can run 1080p h.264 but not a 480p youtube video on fullscreen...) We definitelly going to the wrong way...
samwonderuk Jan 27, 2013 @ 6:25am 
it worked for my steam copy, the files are in my documents then my games etc etc
i agree with you on the rest mate, and if the specs of the next console are to be believed then its gonna be another 10 years of rubbish console ports, the only decent thing about gaming atm is steam and the direction tthey are going in. i cant believe that your rig has a problem with any game but the unreal engine has changed so much that its now a console or smartphone sdk rather than for pc. whats the song called "two steps foward and two steps back" lol
id Jan 27, 2013 @ 8:21am 
hahahaha you can't be more right! About my rig, the cpu actually hold the horses because a single thread isn't powerfull enough. As i said, optimise pc games are for the weak. but it can achieve 30fps or so on any game. I'll try this solution on the files on my documents now.


didn't work... sadly... but if you want to turn the texture streaming off, set HysteresisLimit=0 on defaultengine.ini. this make the game load all the textures before show anything.
samwonderuk Jan 28, 2013 @ 11:28am 
C:\Users\Samuel\Documents\WB Games\Batman Arkham City GOTY\BmGame\Config

thats the file extension on my pc, and thanx for the tip i will give it a try and let you know :)
id Jan 28, 2013 @ 11:38am 
yes, I try to do with the files in these folder. The only thing that do some difference was the triple buffer on the graphic card settings. Again, not a fix, only emends hehehe. I wonder if when they will fix this...
samwonderuk Jan 28, 2013 @ 11:46am 
never now i guess to busy working on the next batman game lol
Dannystaples Jan 29, 2013 @ 5:54am 
I did this but the files are replaced whenever the game restarts which then makes the game go back to being all stuttery. I mean it surely isn't a fix if you have to refix every time you want to play?
samwonderuk Jan 29, 2013 @ 6:01am 
no you have to save the file as a read only after you make the changes, dont just delete the files, read the link in full, it states you need to change something in the config, you only delete them if it dont work so your left with original files
jake_not_the_pizza_guy_thebusker Jan 31, 2013 @ 8:14am 
GFWL was the cause of stuttering on the DX11 version of this game. Seems to cause stuttering if it's attempting to log on while starting the game. Start GFWL first, make sure that's logged on and then start the game. Stops the stuttering on my rig and is a PITA workaround but one that works without editing any *.ini files.
samwonderuk Feb 1, 2013 @ 8:49am 
Originally posted by jakethebusker:
GFWL was the cause of stuttering on the DX11 version of this game. Seems to cause stuttering if it's attempting to log on while starting the game. Start GFWL first, make sure that's logged on and then start the game. Stops the stuttering on my rig and is a PITA workaround but one that works without editing any *.ini files.

nice 1 i shall give it a try. This is why i love steam and their forums, coz actually gamers help out each other as we are all in the same boat(so to speak)
A Distracting Box Feb 1, 2013 @ 1:04pm 
I tried it out and I saw a HUGE improvement when I ran the benchmark. Little to no stuttering at all when rendering the outdoor scene of Arkham City. It's definitely worth a try, but make sure to back up your files just in case.
id Feb 1, 2013 @ 1:15pm 
didn't work... sadly...
Saraph Feb 11, 2013 @ 10:39pm 
Thank you! It worked pretty well for me.

CPU: i7 3770k
GPU: EVGA 670 FTW
RAM: G.Skill Sniper Series @ 1866Mhz
banzaigtv Feb 21, 2013 @ 1:45am 
Thanks. Works for me. Extreme detail, DX 11 with tessellation on high on a GTX 660 and get 55 fps average in benchmark. Tried PhysX on normal, but was getting more fps stutter with it on. Can anyone suggest settings to use if I want PhysX enabled?
id Feb 21, 2013 @ 4:34am 
A second video card. I think that this method works only on intel... I have a AMD and nothing worked...
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Dec 30, 2012 @ 8:58am
Posts: 19