ViggyJams Apr 30, 2013 @ 9:57pm
Stuck on Loading Screen.
Hey guys, so... I attempt to start the game through Steam, and it begins to load like normal, running in a window, and everything seems to be working fine. Then I get to 100%, and it just stays there. I let it sit there for minutes upon minutes and it won't load the title screen at all.
At this point I close out of it and verify the game cashe. It says everything is fine. I try it again and it still doesn't work. So, at this point, I go to realmofthemadgod.com to try the browser version... same thing happens.
The oddest part is, it loaded super slow on all of my attempts, took about 1:00 minute to 1:30 minutes each time.
Does anybody know what the problem is, or if there's a fix for this?
I'm running Windows 7 64-bit.
My browser is the latest stable build of Google Chrome.
Last edited by ViggyJams; Apr 30, 2013 @ 10:00pm
Showing 1-6 of 6 comments
< >
Swaggy May 15, 2013 @ 2:05am 
the same never ending loading screen happens to me to;/
InsaneFirebat May 15, 2013 @ 3:32am 
The long load screens are a side effect of the duping fix. Nothing you can do to prevent it, just something we have to deal with because our community has too many greedy cheaters.
ViggyJams May 15, 2013 @ 3:13pm 
It's not a long load screen, the part where I said it took a long time to load was when opening it. It takes about a minute to a minute and a half "Scanning for steam game updates" and then when it finally gets into the game with the loading screen, it never actually loads and is stuck on the loading screen forever.
I'm unable to play the game... that's not exactly something I can "just deal with"
Last edited by ViggyJams; May 15, 2013 @ 3:14pm
ViggyJams May 15, 2013 @ 10:51pm 
Nevermind, actually... I just tried again, and the initial problem I was having seems to have fixed itself... I can get to the main menu and everything. I've selected a server and a character, and now I've been sitting here on the load screen for at least 10 minutes...

Perhaps it's attempting to connect to the server and this is a port forwarding issue on my end?
Last edited by ViggyJams; May 15, 2013 @ 10:54pm
Nuclear Rabbits May 16, 2013 @ 9:17pm 
i have this problem too I usually just exit and it fixes but not today :s
ViggyJams May 16, 2013 @ 11:31pm 
I tried a different server and was able to connect right away. Anybody having this issue should try a different server.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Apr 30, 2013 @ 9:57pm
Posts: 6