PlagueDoctor Dec 3, 2012 @ 5:58am
Revolution crashes on startup
So, i run the game, the Team 17 logo comes up, the animation on it plays all laggy...
After the logo has gone, the minor loading screen comes, it loads for about 4 seconds and then shuts down the game w/o any error message, i have been googling the problem, but found nothing. What should i do? I have ran the system scan to see if my computer can run the game, and it passes the test with good results..
Showing 1-9 of 9 comments
< >
K_moes Dec 3, 2012 @ 8:39am 
Having the same issue right now. Although it wasn't lagging for me, it just randomly closed out at the same point you said.
PlagueDoctor Dec 3, 2012 @ 9:55am 
Originally posted by K_moes:
Having the same issue right now. Although it wasn't lagging for me, it just randomly closed out at the same point you said.

I found the problem, if you have nvidia drivers, you need to adjust the settings from the nvidia control panel
K_moes Dec 3, 2012 @ 6:22pm 
Apparently I have Intel HD Graphics Family. Have updated all of my drivers and yet I can't play the game. I have tried installing other graphic drivers that are compatible with this game and none have worked. Any solutions?
Ichari Dec 4, 2012 @ 9:19am 
i have this exact problem, and i just want to kill worms!
Bink Dec 4, 2012 @ 7:24pm 
When you say you got the updated drivers, did you get it from Intel or your manufacter's website? I was having the same issue until i went to Intel's site. They have a driver update specifically for worms revolution. If the update was from Intel...I got nothing. Though I'm still incapable of playing the game cause the screen crashes on the next loading screen for me. I don't know if that'll be a problem for you though!
President Vader Dec 4, 2012 @ 11:10pm 
ok i had this same issue, what i did is go to the nvidia control panel and go to manage 3d settings and select programming settings. click add and search for worms folder in the steamapps folder and make it use the High-performance gpu and click apply bottomr right.

This issue occurs when you have a GPU with the nvidia opti (whatever it is called) and you have an intel hd gpu set and a high performance nvidia gpu.
President Vader Dec 4, 2012 @ 11:11pm 
you add the wormsrevolution.exe
Winter is Coming Dec 25, 2012 @ 10:43am 
Originally posted by Admiral Ackbar:
ok i had this same issue, what i did is go to the nvidia control panel and go to manage 3d settings and select programming settings. click add and search for worms folder in the steamapps folder and make it use the High-performance gpu and click apply bottomr right.

This issue occurs when you have a GPU with the nvidia opti (whatever it is called) and you have an intel hd gpu set and a high performance nvidia gpu.
HE said he has Intel
DuckFish Jan 29, 2013 @ 11:45am 
Blink

Originally posted by Bink:
When you say you got the updated drivers, did you get it from Intel or your manufacter's website? I was having the same issue until i went to Intel's site. They have a driver update specifically for worms revolution. If the update was from Intel...I got nothing. Though I'm still incapable of playing the game cause the screen crashes on the next loading screen for me. I don't know if that'll be a problem for you though!
link please.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Dec 3, 2012 @ 5:58am
Posts: 9