Quantum Conundrum
DarkChaplain Sep 13, 2012 @ 1:54am
How to Fix: Gamepad Stick-Axes
Alright, since this is an Unreal Engine game, and the Engine apparently has some issues mainly with non-branded or emulated gamepads, you might encounter issues with movement and the camera controls.

The issue in question would be that moving forward with your left stick would result in the opposite movement direction, aka backwards, and the camera might move up and down instead of left and right.

Thankfully, fixing this is rather easy:

Navigate to this directory (path might vary depending on your OS or Steam install directory):
"C:\Program Files (x86)\Steam\steamapps\common\Quantum Conundrum\Engine\Config"

In this folder, you'll find multiple .ini files.
Open up "BaseInput.ini" with a text editor and find the following lines under
"; --- XBox Bindings":

Bindings=(Name="XboxTypeS_LeftX",Command="Axis aStrafe Speed=1.0 DeadZone=0.3")
Bindings=(Name="XboxTypeS_LeftY",Command="Axis aBaseY Speed=1.0 DeadZone=0.3")
Bindings=(Name="XboxTypeS_RightX",Command="Axis aTurn Speed=1.0 DeadZone=0.2")
Bindings=(Name="XboxTypeS_RightY",Command="Axis aLookup Speed=0.8 DeadZone=0.2")

Those are the two sticks on your gamepad with their corresponding actions.
Now, for me, the Left stick's Y Axis was inverted. What you need to do to fix this is modifying this line:

Bindings=(Name="XboxTypeS_LeftY",Command="Axis aBaseY Speed=1.0 DeadZone=0.3")

The issue will be fixed by adding one single character to this line - we set the "Speed" to "-1.0", thus inverting the stick again, back to how it should be.

Bindings=(Name="XboxTypeS_LeftY",Command="Axis aBaseY Speed=-1.0 DeadZone=0.3")

That fixes the movement. In case the Left/Right movement is inverted for you as well, repeat this step for the LeftX axis.


Now the camera was a bit more screwed for me, namely the X and Y axes being interchanged. The fix is just as simple:

Bindings=(Name="XboxTypeS_RightX",Command="Axis aTurn Speed=1.0 DeadZone=0.2")
Bindings=(Name="XboxTypeS_RightY",Command="Axis aLookup Speed=0.8 DeadZone=0.2")

Needs to be changed to:

Bindings=(Name="XboxTypeS_RightX",Command="Axis aLookup Speed=0.8 DeadZone=0.2")
Bindings=(Name="XboxTypeS_RightY",Command="Axis aTurn Speed=1.0 DeadZone=0.2")

So all you do is switch the commands for the individual axes around. In case they are inverted, refer to the Left stick.
Hint: If you aren't satisfied with the ingame sensitivity settings, you can modify them in this .ini file as well.

Now, maybe your buttons might be switched as well (they weren't for me, but it isn't unheard of). If so, try changing the commands for the individual buttons around to suit your needs - it should be fairly straight forward, though.

After changing things around, save the file and restart the game. You should have a working gamepad now.

One more thing:
You might want to back the BaseInput.ini file up for the future - if you reinstall the game, verify the files or in case of a patch, your changes might get returned to the defaults.

Hope this helps!
Last edited by DarkChaplain; Sep 13, 2012 @ 1:56am
< >
Showing 1-8 of 8 comments
janfebmarch Sep 24, 2012 @ 7:23pm 
Thanks for that! Didn't have to spend time figuring it myself.
DarkChaplain Dec 22, 2012 @ 5:00pm 
I hope this might help people who buy it on the current Flash Deal!

Just reinstalled the game and was glad that I could follow my own guide instead of checking everything again.
MrsKryten Jan 1, 2013 @ 9:37pm 
Thank you for posting this!
DarkChaplain Jan 2, 2013 @ 5:22am 
Originally posted by MrsKryten:
Thank you for posting this!

Glad that it helped!
WhiteLightning Jan 24, 2013 @ 7:14am 
Thanks for posting! :)
LEG3ND Nov 17, 2013 @ 1:12pm 
can you help me im having the same issue with saints row the third
chad28_69 Dec 28, 2014 @ 8:02am 
This is happening to me in Enslaved in the right analog stick (camera). I did what you said but it did nothing. Can you help me? http://steamcommunity.com/app/245280/discussions/0/620700960462887533/
Last edited by chad28_69; Dec 28, 2014 @ 8:03am
i know this is an old post but is there away to turn off/disable keyboard prompts.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50