EazyCheeze Jan 26, 2013 @ 1:56pm
The Warrior Boss Fight; cannot get the rhythm to push him off...
After a year or so and on multiple platforms, I've come back to this game to try once more to get past the Warrior. Finishing him requires pressing the sword button in a specific rhythm.

Now, I've read that I need to start out somewhat slow, ramping up in speed in my button presses, and from the videos I've seen, he should be pushed off in about four seconds if we're just right on our timing...

I've tried very many times (maybe upwards of 50) and I absolutely cannot get the timing right for the life of me! Button mashing doesn't work, I know, but perfectly-timed presses of the button... Is there a video somewhere that shows me, maybe in a splitscreen of the game output and the person's hands on a controller, of how to do this correctly? This is basically the only thing that's stopping me from enjoying this beautiful game. So frustrating.
Showing 1-10 of 10 comments
< >
foxlance Jan 27, 2013 @ 9:22am 
Maybe this can help.

http://www.youtube.com/watch?v=tC4cHS03CRE

Happy gaming!
EazyCheeze Jan 27, 2013 @ 9:59am 
Unfortunately, I've watched many videos like this, but they get me no closer to pushing the Warrior off or getting the proper rhythm because I do not see actual controller input, just the results... Thank you for your help though. I will stick with it until I get it this time, though. I am tempted to Rage Quit the whole thing like I did before, but I won't this time.
current Jan 30, 2013 @ 11:55am 
That's strange. My button-mashing got me through the whole game.
You play this on PC? keyboard/controller? Mb the issue is slow framerate, caused by old hardware. I had some problems in fights where you have to press the specific button in order to dodge the special attack, and the image appeared too late so I could not press the required button in time. All this was because of my kinda old hardware.
EazyCheeze Jan 30, 2013 @ 5:15pm 
I have absolutely smooth 60 frames per second; I had this exact problem on the 360 running at 30, couldn't find the right rhythm. And I've tried both the keyboard/mouse and controller.
twitch.tv/Silhouette0x21 Feb 10, 2013 @ 3:48am 
It's not a specific rhythm, it's simply just mashing the attack button as fast as you can. If that doesn't work for you, then I don't know why, but it did for me.
bloodraven43 Feb 12, 2013 @ 8:24pm 
yeah that x button flashing dosnt mean you push in that rhythm...you button mash that x button...if your not fast enough with both hands on controller....hold with one hand and bash the button over top of it with your index finger...thats what i do...lol
... Apr 7, 2013 @ 4:21am 
I was rage quiting this game few months back for the same reason....today I followed bloodraven advice with success :D. It is the first game ever when my thumb is too slow..lol
[51/50]$tinger Apr 29, 2013 @ 9:21pm 
Had the same problem using keyboard and mouse seems my mouse button wasnt fast enough so i configured the F key on my keyboard for attack and worked like a charm really have to smack it though but it worked.
tenz Mar 23, 2014 @ 9:42am 
Thanks $tinger! I ____***NEVER***___ won ANY quicktime push event in this steam version game (I killed the cocubine and alchemist with this handicap too). Guess my mouse sends the signal out too slow (it is cordless, but i dont think that should matter). Spent 3 hours fighting warrior boss. Nearly punched hole in computer screen.... Finally I switch key to F, mash it like mad, and POOF! First try, I push the darn boss off the edge.
Last edited by tenz; Mar 23, 2014 @ 10:30am
Taya Seloria Mar 26, 2014 @ 8:10pm 
Originally posted by foxlance:
Maybe this can help.

http://www.youtube.com/watch?v=tC4cHS03CRE

Happy gaming!

Thanks for this! I was having trouble trying to figure out how to use the environment against the warrior but I didn't know how. I think this will be one of the harder guardians in the game because he is not weak against attacks or magic.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50