Brometheus Apr 22, 2013 @ 4:26pm
No picture at 1080p
Probably the weirdest problem I've ever seen for any game I've tried.

I would start the game, set the game resolution to 1920x1080 in the game's launcher, the game starts, but the only thing that tells you the game is working is that you can hear the audio, but can't see any picture.

I have an Nvidia card, so I've tested all the resolution scaling options in Nvidia Control Panel as well as checking to make sure my refresh rate is set to 60Hz, but nothing allows this game to work at 1080p. Literally the only way to get picture to display is by setting the game's resolution to anything lower than 1920x1080 in the launcher. Any help would be great.
Showing 1-5 of 5 comments
< >
jarasm Nov 11, 2013 @ 12:43pm 
Hi, did you find any solution for this? I have exactly the same problem - can't see anything unless I set the resolution below my native 1080p.
Brometheus Nov 11, 2013 @ 3:58pm 
  • Browse to your Prince of Persia install directory
  • Look for PrinceOfPersia_Launcher.exe > Right-click > Properties
  • Click on the Compatibility tab
  • Tick the checkbox to enable running the program in a compatibility mode
  • Choose Windows Vista (Service Pack 2) > Apply > OK
  • Run the game as per normal through your Steam library
  • Go to Settings > select 1080p > tick the Widescreen checkbox > tick the Vertical Sync checkbox (other graphics settings set yourself at your leisure)
  • Hit OK to save settings, then hit the "Launch the game!" button

HOPEFULLY that should work for you. If I'm not mistaken, I believe I was still on Win7 when I had this issue and eventually figured it out. Since then, I have upgraded to Win8 and these settings are still working for me.
Last edited by Brometheus; Nov 11, 2013 @ 4:00pm
@FL Nov 12, 2013 @ 9:54am 
Hi, did you find any solution for this? I have exactly the same problem - can't see anything unless I set the resolution below my native 1080p.
Brometheus Nov 12, 2013 @ 10:35am 
Originally posted by SuPp3:
Hi, did you find any solution for this? I have exactly the same problem - can't see anything unless I set the resolution below my native 1080p.

Are you and jarasm the same person? lol.

Anyway, try following the instructions in the post just above yours and hopefully that should do it.
jarasm Nov 13, 2013 @ 1:49pm 
I don't THINK we're the same person. At least not that I'm aware of.

Anyway, thanks! Actually I figured this one out on my own when I started fumbling with the compatibility settings, just wanted to drop by to share this and found your reply :) So, thanks again, and good luck to whoever else needs this and comes upon this info.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50