greggschaffter Nov 24, 2012 @ 6:18pm
Source FIlmmaker won't start up
So, I recently just downloaded Source Filmmaker, but it won't launch. I have a Source game(TF2), I am running windows 7 and my computer can processes it if would run. When I try running it, it says it is starting it, but it never actually runs.
Last edited by greggschaffter; Nov 24, 2012 @ 6:20pm
Showing 1-15 of 30 comments
< >
Fapdapalap Nov 24, 2012 @ 6:50pm 
doesn't work for me either
greggschaffter Nov 24, 2012 @ 8:29pm 
Can someone please help?
Pte Jack Nov 24, 2012 @ 9:06pm 
Validate your TF2 Game Cache and the cache for SFM. There have been a lot of updates lately and your cache maybe out of date. If all else fails, Right Click on SFM in the start menu, Delete Local Content and reinstall.
greggschaffter Nov 24, 2012 @ 11:37pm 
I tried that, and it still doesn't work. I really want to use this great program. :(
Nov 25, 2012 @ 2:58am 
look at the procces ctrl+alt+surpr and if SFM do not open, stop process sfm and try to re-open it
Last edited by ; Nov 25, 2012 @ 2:58am
greggschaffter Nov 25, 2012 @ 3:26am 
I already tried that, it doesn.t work. I noticed that the processes it shows that SFM opened, but it doesn't open.
Method 'Nan Nov 25, 2012 @ 6:32am 
It also doesn't work for me. I think all of the people trying to use it for the Saxxy Awards might've caused some issues, but I'm not sure.
Pte Jack Nov 25, 2012 @ 8:46am 
I'm sure you've already verified this but check your hardware and compare it with this FAQ. Just because you can run HL2, TF2 and other valve games doesn't meatn your system will run SFM

Q. What are the hardware requirements?
OS: Windows 7 / Vista (Windows 7 64 bit suggested)
Processor: 3.0 GHz P4, Dual Core 2.0 (or higher) or AMD64X2 (or higher)
Memory: 2GB (4 GB suggested)
Hard Disk Space: At least 15 GB of Space
Video: NVIDIA GeForce 200 series card or better, or AMD Radeon 3000 series or better (NVIDIA GeForce 400 series or AMD Radeon 5000 series preferred)
Monitor: 1366 x 768 (1920 x 1080 suggested)
Audio: DirectX 9.0c compatible
USB headset with mic (suggested)
greggschaffter Nov 25, 2012 @ 11:50am 
Checked all requirements, and they check out.
Pte Joe Nov 25, 2012 @ 3:08pm 
Nope, the Saxxys don't have anything to do with SFM not starting. the problem lies on your side. I would suggest that you right click on the SFM start link from the library, delete local content and reinstall the program.
greggschaffter Nov 25, 2012 @ 9:47pm 
I have already done that 5 times.
Pte Jack Nov 26, 2012 @ 8:59am 
what are your computer specs?

Inparticular your graphics card?
Denzel Feb 9, 2013 @ 1:16pm 
Yeah, hi, I'm having a similar problem.
What happens with me is that I can open SFM and it shows it as running and everything is fine and all, but there is no window... It's just sitting there in my task bar doing nothing.
I can make a new session or load an old one, but the actual SFM window won't show up.
I know this has nothing to do with what my specs are, since I have been able to run SFM prior.
Pte Jack Feb 9, 2013 @ 8:20pm 
It may be minimized to a small block on your screen. look for it and resizr the window. If you have a cluttered desktop, try hiding desktop icons, the box left over may be SFM
Patchy the MLG Quickscoper Feb 10, 2013 @ 5:42am 
When I open SFM it starts up, and then crashes.
I checked all of the requirements.
Please Help.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50